Trie树题目模板及java代码
Posted 知道什么是码怪吗?
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Trie树题目模板及java代码相关的知识,希望对你有一定的参考价值。
Trie字符串统计
维护一个字符串集合,支持两种操作:
I x
向集合中插入一个字符串 x;Q x
询问一个字符串在集合中出现了多少次。
共有 N 个操作,输入的字符串总长度不超过 10^5,字符串仅包含小写英文字母。
输入格式
第一行包含整数 N,表示操作数。
接下来 N 行,每行包含一个操作指令,指令为 I x
或 Q x
中的一种。
输出格式
对于每个询问指令 Q x
,都要输出一个整数作为结果,表示 x 在集合中出现的次数。
每个结果占一行。
数据范围
1≤N≤2∗10^4
输入样例:
5
I abc
Q abc
Q ab
I ab
Q ab
输出样例:
1
0
1
代码:
import java.util.*;
public class Main {
static int Index = 0;//可以将Index理解为插入的节点个数
static int[][] ch = new int[100010][26];
static int[] cnt = new int[100010];
public static void Insert(String str) {
int p = 0;
for (int i = 0; i < str.length(); i++) {
int a = str.charAt(i) - 'a';
if (ch[p][a] == 0)// 如果字符对应的路径没有开通
ch[p][a] = ++Index;// 开通这个字符对应的路,然后标明是第几个插入的节点
p = ch[p][a];//p跳转到这一个节点
}
cnt[p]++;
}
public static int Query(String str) {
int p = 0;
for (int i = 0; i < str.length(); i++) {
int a = str.charAt(i) - 'a';
if (ch[p][a] == 0)
return 0;
p = ch[p][a];
}
return cnt[p];
}
public static void main(String args[]) {
Scanner input = new Scanner(System.in);
int n = input.nextInt();
for (int i = 0; i < n; i++) {
String ch1 = input.next();
String str1 = input.next();
if (ch1.equals("I"))
Insert(str1);
else
System.out.println(Query(str1));
}
}
}
最大异或对
在给定的 N 个整数 A1,A2……AN 中选出两个进行 xor(异或)运算,得到的结果最大是多少?
输入格式
第一行输入一个整数 N。
第二行输入 N 个整数 A1~AN。
输出格式
输出一个整数表示答案。
数据范围
1≤N≤10^5
0≤Ai<2^31
输入样例:
3
1 2 3
输出样例:
3
代码:
import java.util.*;
public class Main {
static int Index = 0;// 记录新加入的节点
static int[] nums = new int[100010];
static int[][] node = new int[3100010][2];
public static void Insert(int number) {// 将这个数按照二进制的方式插入到树中
int p = 0;
for (int i = 30; i >= 0; i--) {// 最大的数表示为2进制,构成的树最深31层
int s = node[p][number >> i & 1];
if (s == 0) {
s = ++Index;
node[p][number >> i & 1] = s;
}
p = s;
}
}
public static int Search(int number) {
int p = 0;
int result = 0;
for (int i = 30; i >= 0; i--) {
int a = number >> i & 1;// 获取第i位的数字
if (node[p][a ^ 1] > 0) {// a=1,走0 a=0,走1
result += 1 << i;
p = node[p][a ^ 1];
} else
p = node[p][a];
}
return result;
}
public static void main(String args[]) {
Scanner input = new Scanner(System.in);
int n = input.nextInt();
for (int i = 0; i < n; i++) {
nums[i] = input.nextInt();
Insert(nums[i]);
}
int maxVal = 0;
for (int i = 0; i < n; i++)
maxVal = Integer.max(maxVal, Search(nums[i]));
System.out.println(maxVal);
}
}
以上是关于Trie树题目模板及java代码的主要内容,如果未能解决你的问题,请参考以下文章