ybtoj 11.13 S组暴力A. 他的世界

Posted SSL_ZZL

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ybtoj 11.13 S组暴力A. 他的世界相关的知识,希望对你有一定的参考价值。

A. 他的世界

ybtoj 11.13 S组 A. 他的世界


题面

样例
样例输入

4 
1 5 
100 5 
10000 5 
1000000 5

样例输出

5 7 11 15 19 
104 106 116 128 132 
10016 10019 10023 10034 10035 
1000003 1000009 1000011 1000026 1000031


解题思路

当ybtoj有了签到题

直接暴力从 n 开始找钻石羊毛数,找 m 个就好了,并不超时
虽然长得像数位DP之类的,但雀食是暴力😅


Code

#include <bits/stdc++.h>
#define ll long long

using namespace std; 

ll T, n, m;

int check(ll x) {
	int l = 0, r = 0;
	while(x) {
		if(x % 3 == 1) l ++;
		if(x % 3 == 2) r ++;
		x /= 3;
	}
	return (l == r);
}

int main() {
	freopen("number.in", "r", stdin);
	freopen("number.out", "w", stdout);
	scanf("%lld", &T);
	while(T --) {
		scanf("%lld %lld", &n, &m);
		for(ll i = n, k = 1; k <= m; i ++)
			if(check(i)) k ++, printf("%lld ", i);
		printf("\\n");
	}
}

以上是关于ybtoj 11.13 S组暴力A. 他的世界的主要内容,如果未能解决你的问题,请参考以下文章

ybtoj 11.13 S组二分BFSD. 道路与航线

ybtoj比赛 9.20B组 A博弈论棋盘战争

ybtoj 字符串进阶A. 1.生日排序

ybtoj 二分进阶A. 1.喂养宠物

ybtoj 宽搜进阶二分A. 1.最小权值

ybtoj 贪心 A. 2.最大积分