1054 求平均值 (20 分)
Posted 再吃一个橘子
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1054 求平均值 (20 分)相关的知识,希望对你有一定的参考价值。
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number
,其中 X
是输入。最后在一行中输出结果:The average of K numbers is Y
,其中 K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined
替换 Y
。如果 K
为 1,则输出 The average of 1 number is Y
。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
思路:
- 将字符转换成指定格式,判断是否为合法浮点数
- 判断完以后即可根据有效数的个数进行分类输出即可。
AC代码
#include <stdio.h>
int main() {
int n, i, j, cnt = 0;//cnt记录合法数目个数
scanf("%d", &n);
char arr[50], sam[50];//存储输入的字符,存储格式化后的字符串
double sum = 0, tmp;//sum总和,实数tmp
for (i = 0; i < n; i++) {
scanf("%s", arr);
sscanf(arr, "%lf", &tmp);//从一个字符串中读进与指定格式相符的数据
sprintf(sam, "%.2lf", tmp);//字符串格式化命令,主要功能是把格式化的数据写入某个字符串中
int flag = 0;
for (j = 0; j < strlen(arr); j++) {//strlen()计算指定字符串arr的长度
if (arr[j] != sam[j]) { flag = 1; break; }
}
if (flag == 1 || tmp < -1000 || tmp> 1000) {
printf("ERROR: %s is not a legal number\\n", arr);
//continue;
}
else {
sum += tmp;//求和
cnt++;
}
}
if (cnt > 1) printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
if (cnt == 1) printf("The average of 1 number is %.2lf", sum);
if (cnt == 0) printf("The average of 0 numbers is Undefined");
return 0;
}
以上是关于1054 求平均值 (20 分)的主要内容,如果未能解决你的问题,请参考以下文章