POJ 2653 Pick-up sticks [计算几何,线段相交]
Posted 霜序0.2℃
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 2653 Pick-up sticks [计算几何,线段相交]相关的知识,希望对你有一定的参考价值。
题目
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
Input
Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.
The picture to the right below illustrates the first case from input.
Sample Input
5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0
Sample Output
Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.
Hint
Huge input,scanf is recommended.
解释与代码
kuangbin的板子
真就无脑暴力呗,正好卡在时限内,再多一点就超时了
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <iostream>
#include <sstream>
#include <set>
#include <map>
#include <queue>
#include <bitset>
#include <vector>
#include <limits.h>
#include <assert.h>
#include <functional>
#include <numeric>
#include <ctime>
//#include <ext/pb_ds/assoc_container.hpp>
//#include <ext/pb_ds/tree_policy.hpp>
#define pb push_back
#define ppb pop_back
#define lbnd lower_bound
#define ubnd upper_bound
#define endl '\\n'
#define trav(a, x) for(auto& a : x)
#define all(a) (a).begin(),(a).end()
#define F first
#define S second
#define sz(x) (ll)x.size()
#define hell 1000000007
#define DEBUG cerr<<"/n>>>I'm Here<<</n"<<endl;
#define display(x) trav(a,x) cout<<a<<" ";cout<<endl;
#define what_is(x) cerr << #x << " is " << x << endl;
#define ini(a) memset(a,0,sizeof(a))
#define case ll T;read(T);for(ll Q=1;Q<=T;Q++)
#define lowbit(x) x&(-x)
#define pr printf
#define sc scanf
//#define _ 0
#define FAST ios_base::sync_with_stdio(false);cin.tie(0);cout.tie(0);
#define DBG(x) \\
(void)(cout << "L" << __LINE__ \\
<< ": " << #x << " = " << (x) << '\\n')
#define TIE \\
cin.tie(0);cout.tie(0);\\
ios::sync_with_stdio(false);
//#define long long int
//using namespace __gnu_pbds;
template <typename T>
void read(T &x) {
x = 0;
int f = 1;
char ch = getchar();
while (!isdigit(ch)) {
if (ch == '-') f = -1;
ch = getchar();
}
while (isdigit(ch)) {
x = x * 10 + (ch ^ 48);
ch = getchar();
}
x *= f;
return;
}
inline void write(long long x) {
if(x<0) putchar('-'), x=-x;
if(x>9) write(x/10);
putchar(x%10+'0');
putchar('\\n');
}
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const double pi = acos(-1.0);
const double eps = 1e-8;
const int INF = 0x3f3f3f3f;
const ll LLINF = 0x3f3f3f3f3f3f3f3f;
const int maxn = 200009;
const ll N = 5;
const double inf=1e20;
const int maxp=1010;
//判断正负
int sgn(double x) {
if (fabs(x)<eps) return 0;
if (x<0) return -1;
else return 1;
}
//平方
inline double sqr(double x) {
return x*x;
}
struct Point {
double x,y;
Point() {}
Point(double _x, double _y) {
x=_x;
y=_y;
}
void input() {
scanf("%lf%lf",&x,&y);
}
void output() {
printf("%.2f%.2f\\n",x,y);
}
bool operator == (Point b)const {
return sgn(x-b.x)==0 && sgn(y-b.y)==0;
}
bool operator < (Point b)const {
return sgn(x-b.x)==0?sgn(y-b.y)<0:x<b.x;
}
Point operator -(const Point &b)const {
return Point(x-b.x,y-b.y);
}
//叉积
double operator ^(const Point &b)const {
return x*b.y-y*b.x;
}
//点积
double operator *(const Point &b)const {
return x*b.x+y*b.y;
}
//返回长度
double len() {
return hypot(x,y);
}
//返回长度平方
double len2() {
return x*x+y*y;
}
//返回两点间距
double distance(Point p) {
return hypot(x-p.x,y-p.y);
}
Point operator +(const Point &b)const {
return Point(x+b.x,y+b.y);
}
Point operator *(const double &k)const {
return Point(x*k,y*k);
}
Point operator /(const double &k)const {
return Point(x/k,y/k);
}
//pa和pb的夹角
double rad(Point a,Point b) {
Point p=*this;
return fabs(atan2(fabs((a-p)^(b-p)),(a-p)*(b-p)));
}
//化为长度为r的向量
Point trunc(double r) {
double l=len();
if (!sgn(l)) return *this;
r/=l;
return Point(x*r,y*r);
}
//逆时针旋转 90 度
Point rotleft() {
return Point(-y,x);
}
//顺时针旋转 90 度
Point rotright() {
return Point(y,-x);
}
//绕着 p 点逆时针旋转 angle
Point rotate(Point p,double angle) {
Point v=(*this)-p;
double c=cos(angle),s=sin(angle);
return Point(p.x+v.x*c-v.y*s,p.y+v.x*s+v.y*c);
}
};
struct Line {
Point s,e;
Line() {}
Line(Point _s,Point _e) {
s=_s;
e=_e;
}
bool operator ==(Line v) {
return (s==v.s) && (e==v.e);
}
//根据一个点和倾斜角 angle 确定直线,0<=angle<π
Line(Point p, double angle) {
s=p;
if (sgn(angle-pi/2)==0) {
e=(s+Point(0,1));
}
else {
e=(s+Point(1,tan(angle)));
}
}
//ax+by+c=0
Line(double a,double b,double c) {
if(sgn(a)==0) {
s=Point(0,-c/b);
e=Point(1,-c/b);
}
else if(sgn(b)==0) {
s=Point(-c/a,0);
e=Point(-c/a,1);
}
else {
s=Point(0,-c/b);
e=Point(1,(-c-a)/b);
}
}
void input() {
s.input();
e.input();
}
void adjust() {
if(e<s) swap(s,e);
}
//求线段长度
double length() {
return s.distance(e);
}
//返回直线倾斜角 0<=angle<π
double angle() {
double k=atan2(e.y-s.y,e.x-s.x);
if(sgn(k)<0) k+=pi;
if(sgn(k-pi)==0) k-= pi;
return k;
}
//点和直线关系
// 1 在左侧
// 2 在右侧
// 3 在直线上
int relation(Point p) {
int c=sgn((p-s)^(e-s));
if(c<0) return 1;
else if(c>0) return 2;
else return 3;
}
//点在线段上的判断
bool pointonseg(Point p) {
return sgn((p-s)^(e-s))==0 && sgn((p-s)*(p-e))<=0;
}
//两向量平行 (对应直线平行或重合)
bool parallel(Line v) {
return sgn((e-s)^(v.e-v.s))==0;
}
//两线段相交判断
//2 规范相交
//1 非规范相交
//0 不相交
int segcrossseg(Line v) {
int d1=sgn((e-s)^(v.s-s));
int d2=sgn((e-s)^(v.e-s));
int d3=sgn((v.e-v.s)^(s-v.s));
int d4=sgn((v.e-v.s)^(e-v.s));
if((d1^d2)==-2&&(d3^d4)==-2)return 2;
return (d1==0 && sgn((v.s-s)*(v.s-e))<=0) ||
(d2==0 && sgn((v.e-s)*(v.e-e))<=0) ||
(d3==0 && sgn((s-v.s)*(s-v.e))<=0) ||
(d4==0 && sgn((e-v.s)*(e以上是关于POJ 2653 Pick-up sticks [计算几何,线段相交]的主要内容,如果未能解决你的问题,请参考以下文章
POJ 2653 Pick-up sticks [计算几何,线段相交]
POJ_2653_Pick-up sticks_判断线段相交