HDU2000 ASCII码排序字符排序
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU2000 ASCII码排序字符排序相关的知识,希望对你有一定的参考价值。
ASCII码排序
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 332781 Accepted Submission(s): 129299
Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z
Author
lcy
Source
C语言程序设计练习(一)
问题链接:HDU2000 ASCII码排序
问题简述:(略)
问题分析:
按Markdown格式重写了题解,旧版题解参见参考链接。
使用C++排序算法函数sort()来实现是一种简便的方法,给出2种不同的调用排序函数的题解程序。
还有一种解法是组合比较交换,算出顺序再输出。这种做法程序逻辑比较简单。程序基于输入逻辑、输出逻辑与计算逻辑分离的考虑。比较与交换的顺序按冒泡排序思想来做。
最后一种做法是编写通用排序程序来解决,按冒泡排序思想来编程。通用排序程序的优点是代码可以复用,即可以拷贝粘贴到别的地方使用。程序员应该尽量编写通用程序。
程序说明:(略)
参考链接:HDU2000 ASCII码排序【字符串排序】
题记:杀鸡也可以用宰牛刀。
AC的C++语言程序(通用排序:冒泡排序)如下:
/* HDU2000 ASCII码排序 */
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
const int N = 3;
int main()
{
string s;
while(getline(cin, s)) {
/* 冒泡排序 */
for (int i = 1; i < N; i++)
for (int j = 0; j < N - i; j++)
if (s[j] > s[j + 1]) {
char tmp = s[j];
s[j] = s[j + 1];
s[j + 1] = tmp;
}
for (int i = 0; i < N; i++) {
if (i != 0) cout << " ";
cout << s[i];
}
cout << endl;
}
return 0;
}
AC的C语言程序(组合比较交换)如下:
/* HDU2000 ASCII码排序 */
#include <stdio.h>
int main(void)
{
char a, b, c, temp;
while(~scanf("%c%c%c", &a, &b, &c)) {
getchar();
if(a > b) {
temp = a;
a = b;
b = temp;
}
if(b > c) {
temp = b;
b = c;
c = temp;
}
if(a > b) {
temp = a;
a = b;
b = temp;
}
printf("%c %c %c\\n", a, b, c);
}
return 0;
}
AC的C++语言程序(字符排序之二)如下:
/* HDU2000 ASCII码排序 */
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
const int N = 3;
int main()
{
string s;
while(getline(cin, s)) {
sort(s.begin(), s.end());
for(int i=0; i<N; i++) {
if(i != 0)
cout << " ";
cout << s[i];
}
cout << endl;
}
return 0;
}
AC的C++语言程序(字符排序之一)如下:
/* HDU2000 ASCII码排序 */
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
char c[3];
while(scanf("%c%c%c", &c[0], &c[1], &c[2]) != EOF) {
getchar();
sort(c, c + 3);
printf("%c %c %c\\n", c[0], c[1], c[2]);
}
return 0;
}
以上是关于HDU2000 ASCII码排序字符排序的主要内容,如果未能解决你的问题,请参考以下文章