[PTA]1004 成绩排名
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]1004 成绩排名相关的知识,希望对你有一定的参考价值。
读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为
第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩
其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。
输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
结尾无空行
输出样例:
Mike CS991301
Joe Math990112
结尾无空行
- 提交结果:
- 源码:
import java.util.Scanner;
/**
* @author Spring-_-Bear
* @version 2021/9/26 16:24
*/
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int n = scanner.nextInt();
/**
* The information string of each student
*/
String[] students = new String[n];
/**
* Absorb the '\\n'
*/
scanner.nextLine();
for (int i = 0; i < n; i++) {
students[i] = scanner.nextLine();
}
int minScore = 999;
int maxScore = -1;
String maxStudent = " ";
String minStudent = " ";
for (int i = 0; i < n; i++) {
/**
* Split the student information string into string array
* student[0]: name; student[1]: num; student[2]: score;
*/
String[] student = students[i].split(" ");
int curScore = Integer.valueOf(student[2]);
/**
* Update the minimum score
*/
if (curScore < minScore) {
minScore = curScore;
minStudent = students[i];
}
/**
* Update the maximum score
*/
if (curScore > maxScore) {
maxScore = curScore;
maxStudent = students[i];
}
}
/**
* Split the max and min student information string into student array.
* Then print the name and num
*/
String[] max = maxStudent.split(" ");
String[] min = minStudent.split(" ");
System.out.println(max[0] + " " + max[1]);
System.out.println(min[0] + " " + min[1]);
}
}
以上是关于[PTA]1004 成绩排名的主要内容,如果未能解决你的问题,请参考以下文章