POJ 1611 The Suspects [并查集]

Posted 布图

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1611 The Suspects [并查集]相关的知识,希望对你有一定的参考价值。

题目

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

解释与代码

原本想用set来存的,后来发现不行,会漏掉情况

参考了博客https://blog.csdn.net/sr_19930829/article/details/37900239

用一个数组来存每一个根包含的元素数量,然后特判根是0的情况

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <iostream>
#include <sstream>
#include <set>
#include <map>
#include <queue>
#include <bitset>
#include <vector>
#include <limits.h>
#include <assert.h>
#include <functional>
#include <numeric>
#include <ctime>
//#include <ext/pb_ds/assoc_container.hpp>
//#include <ext/pb_ds/tree_policy.hpp>
#define pb          push_back
#define ppb         pop_back
#define lbnd        lower_bound
#define ubnd        upper_bound
#define endl        '\\n'
#define mll         map<ll,ll>
#define msl         map<string,ll>
#define mls         map<ll, string>
#define rep(i,a,b)  for(ll i=a;i<b;i++)
#define repr(i,a,b) for(ll i=b-1;i>=a;i--)
#define trav(a, x)  for(auto& a : x)
#define pll         pair<ll,ll>
#define vl          vector<ll>
#define vll         vector<pair<ll, ll>>
#define vs          vector<string>
#define all(a)      (a).begin(),(a).end()
#define F           first
#define S           second
#define sz(x)       (ll)x.size()
#define hell        1000000007
#define DEBUG       cerr<<"/n>>>I'm Here<<</n"<<endl;
#define display(x)  trav(a,x) cout<<a<<" ";cout<<endl;
#define what_is(x)  cerr << #x << " is " << x << endl;
#define ini(a)      memset(a,0,sizeof(a))
#define ini2(a,b)   memset(a,b,sizeof(a))
#define case        ll T;read(T);for(ll Q=1;Q<=T;Q++)
#define lowbit(x)   x&(-x)
#define pr          printf
#define sc          scanf
#define _           0
#define ordered_set tree<ll, null_type,less<ll>, rb_tree_tag,tree_order_statistics_node_update>
#define FAST ios_base::sync_with_stdio(false);cin.tie(0);cout.tie(0);
#define DBG(x) \\
    (void)(cout << "L" << __LINE__ \\
    << ": " << #x << " = " << (x) << '\\n')
#define TIE \\
    cin.tie(0);cout.tie(0);\\
    ios::sync_with_stdio(false);
//#define long long int

//using namespace __gnu_pbds;

template <typename T>  
void read(T &x) {  
    x = 0;  
    int f = 1;  
    char ch = getchar();  
    while (!isdigit(ch)) {  
        if (ch == '-') f = -1;  
        ch = getchar();  
    }  
    while (isdigit(ch)) { 
        x = x * 10 + (ch ^ 48);  
        ch = getchar();  
    }  
    x *= f;  
    return;  
}

inline void write(long long x) {
    if(x<0) putchar('-'), x=-x;
    if(x>9) write(x/10);
    putchar(x%10+'0');
    putchar('\\n');
}

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const double PI    = acos(-1.0);
const double eps   = 1e-6;
const int    INF   = 0x3f3f3f3f;
const ll     LLINF = 0x3f3f3f3f3f3f3f3f;
const int    maxn  = 300090;
const ll     N     = 5;

int fa[maxn];
int arr[maxn];
int sum[maxn];

set<int> ma;

int get(int x) {
	if (x == fa[x]) return x;
	return fa[x] = get(fa[x]);
}

void merge(int x, int y) {
	x = get(x), y = get(y);
	if (x == y) return ;
	else if (x == 0) {
		fa[y] = 0;
		sum[0] += sum[y];
	} else if (y == 0){
		fa[x] = 0;
		sum[0] += sum[x];
	} else {
		fa[x] = y;
		sum[y] += sum[x];
	}
}

void solve(){
	int n, m, t;
	while (cin>>n>>m) {
		if (n == 0 && m == 0) return ;
//		ma.insert(0);
//		int ans = 1;
		for (int i=0; i<maxn; i++) fa[i] = i, sum[i] = 1;
		for (int I=0; I<m; I++) {
			cin>>t;
			for (int i=0; i<t; i++) {
				cin>>arr[i];
			}
			for (int i=1; i<t; i++) {
				merge(arr[i], arr[i-1]);
			}
		}
		cout<<sum[0]<<endl;
		ma.clear();
	}
	
}

int main()
{
//	TIE;
    #ifndef ONLINE_JUDGE
//    freopen ("in.txt" , "r", stdin );
//    freopen ("out.txt", "w", stdout);
    #else
    #endif
	solve();
//    case{solve();}
//    case{cout<<"Case "<<Q<<":"<<endl;solve();}
	return ~~(0^_^0);
}

以上是关于POJ 1611 The Suspects [并查集]的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1611 ---The Suspects(并查集)

POJ 1611 The Suspects [并查集]

POJ 1611 :The Suspects(并查集)

[并查集] POJ 1611 The Suspects

并查集POJ1611 The Suspects

The Suspects POJ - 1611 并查集,同集合的数