(蓝桥杯)试题 算法训练 最大最小公倍数
Posted nuist__NJUPT
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了(蓝桥杯)试题 算法训练 最大最小公倍数相关的知识,希望对你有一定的参考价值。
试题 算法训练 最大最小公倍数
资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
已知一个正整数N,问从1~N中任选出三个数,他们的最小公倍数最大可以为多少。
输入格式
输入一个正整数N。
输出格式
输出一个整数,表示你找到的最小公倍数。
样例输入
9
样例输出
504
数据规模与约定
1 <= N <= 106。
import java.math.BigInteger;
import java.util.Scanner;
public class Main{
public static void main(String[] args){
Scanner input = new Scanner(System.in) ;
int n = input.nextInt() ;
BigInteger result = new BigInteger("" + 0) ;
if(n<=2){
result = new BigInteger("" + n) ;
}
if(n%2==1){ //n是奇数,两奇加一偶最大
result = new BigInteger(n + "").multiply(new BigInteger((n-1) +"")).multiply(new BigInteger((n-2) + "")) ;
}else{ //n是偶数
if(n%3==0){
result = new BigInteger((n-1) + "").multiply(new BigInteger((n-2) +"")).multiply(new BigInteger((n-3) + "")) ;
}else{
result = new BigInteger(n + "").multiply(new BigInteger((n-1) +"")).multiply(new BigInteger((n-3) + "")) ;
}
}
System.out.println(result) ;
}
}
以上是关于(蓝桥杯)试题 算法训练 最大最小公倍数的主要内容,如果未能解决你的问题,请参考以下文章