渡河问题(Crossing River)-贪心策略
Posted nuist__NJUPT
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了渡河问题(Crossing River)-贪心策略相关的知识,希望对你有一定的参考价值。
Crossing River
group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10
Sample Output
17
import java.util.Arrays;
import java.util.Scanner;
public class Main {
public static void greedy(int N, int [] speeds){
int left = N ; //还未渡河的人数
int times = 0 ; //初始化渡河所需的总时间
while(left > 0){
if(left == 1){
times += speeds[0] ;
break ;
}else if(left == 2){
times += speeds[1] ;
break ;
}else if(left == 3){
times += speeds[0] + speeds[1] + speeds[2] ;
break ;
}else{//两种渡河策略
//快慢分组法:1,2渡河,1回来,3,4渡河,2回来
int s1 = speeds[1] + speeds[0] + speeds[left-1] + speeds[1] ;
//快带慢法:1,4渡河,1回来,1,3渡河,1回来
int s2 = speeds[left-1] + speeds[left-2] + 2 * speeds[0] ;
times += Math.min(s1, s2) ;
left -= 2 ; //所需渡河人数减少2
}
}
System.out.println(times) ;
}
public static void main(String[] args){
Scanner input = new Scanner(System.in) ;
int T = input.nextInt() ;
for(int i=0; i<T; i++){
int N = input.nextInt() ;
int [] speeds = new int [N] ;
for(int j=0; j<N; j++){
speeds[j] = input.nextInt() ;
}
Arrays.sort(speeds) ;
greedy(N, speeds) ;
}
}
}
以上是关于渡河问题(Crossing River)-贪心策略的主要内容,如果未能解决你的问题,请参考以下文章
[BZOJ1617][Usaco2008 Mar]River Crossing渡河问题
[bzoj 1617]: [Usaco2008 Mar]River Crossing渡河问题 dp
1617: [Usaco2008 Mar]River Crossing渡河问题(dp)
BZOJ 1617 [Usaco2008 Mar]River Crossing渡河问题:dp