(蓝桥杯)试题 算法训练 排列

Posted nuist__NJUPT

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了(蓝桥杯)试题 算法训练 排列相关的知识,希望对你有一定的参考价值。

试题 算法训练 排列

资源限制
时间限制:1.0s 内存限制:256.0MB
  排列
问题描述
  给定一个N,输出N的所有排列中按字典序排名的第M个.
输入格式
  共一行.两个数为N,M.
输出格式
  共一行.为N的一个排列.
样例输入
3 3
样例输出
2 1 3
数据规模和约定
  N<=9.

import java.util.Scanner;

public class Main {
    public static int count  = 0;
    public static void permutation(String prefix, char [] arr, int M){
        if(prefix.length() == arr.length){
            count ++ ;
            if(count == M){
                for(int i=0; i<prefix.length(); i++){
                    System.out.print(prefix.charAt(i) + " ") ;
                }
                System.exit(0) ;
            }
        }
        for(int i=0; i<arr.length; i++){
            char c = arr[i] ;
            if(f(arr,c) > f(prefix.toCharArray(),c)) {
                permutation(prefix + c, arr, M);
            }
        }
    }
    public static int f(char [] arr, char c){
        int sum = 0 ;
        for(int i=0; i<arr.length; i++){
            if(c == arr[i]){
                sum ++ ;
            }
        }
        return sum ;
    }
    public static void main(String[] args){
        Scanner input = new Scanner(System.in);
        int N = input.nextInt() ;
        int M = input.nextInt() ;
        String s = "" ;
        for(int i=1; i<=N; i++){
            s += i ;
        }
        permutation("", s.toCharArray(), M) ;
    }
}

以上是关于(蓝桥杯)试题 算法训练 排列的主要内容,如果未能解决你的问题,请参考以下文章

蓝桥杯试题 算法训练 数字游戏

蓝桥杯试题 算法训练 数字游戏

(蓝桥杯)试题 算法训练 数的计数

(蓝桥杯)试题 算法训练 孪生素数

(蓝桥杯)试题 算法训练 观星

(蓝桥杯)试题 算法训练 加法分解