(蓝桥杯)试题 算法训练 数字统计
Posted nuist__NJUPT
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了(蓝桥杯)试题 算法训练 数字统计相关的知识,希望对你有一定的参考价值。
试题 算法训练 数字统计
资源限制
时间限制:1.0s 内存限制:64.0MB
问题描述
请统计某个给定范围[L, R]的所有整数中,数字2 出现的次数。 比如给定范围[2, 22],数字2 在数2 中出现了1 次,在数12 中出现1 次,在数20 中出现1 次,在数21 中出现1 次,在数22 中出现2 次,所以数字2 在该范围内一共出现了6次。
输入格式
输入共1 行,为两个正整数L 和R,之间用一个空格隔开。
输出格式
输出共1 行,表示数字2 出现的次数。
样例输入
Sample Input1:
2 22
Sample Input2:
2 100
样例输出
Sample Output1:
6
Sample Output2:
20
数据规模和约定
1 ≤ L ≤ R≤ 10000。
import java.util.Scanner;
public class Main {
public static int count(int n){
String s = String.valueOf(n) ;
int sum = 0 ;
for(int i=0; i<s.length(); i++){
if(s.charAt(i) == '2'){
sum ++ ;
}
}
return sum ;
}
public static void main(String[] args){
Scanner input = new Scanner(System.in) ;
int L = input.nextInt() ;
int R = input.nextInt() ;
int sum = 0 ;
for(int i=L; i<=R; i++){
sum += count(i) ;
}
System.out.println(sum) ;
}
}
以上是关于(蓝桥杯)试题 算法训练 数字统计的主要内容,如果未能解决你的问题,请参考以下文章