hdu1062 Text Reverse

Posted g0rez

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu1062 Text Reverse相关的知识,希望对你有一定的参考价值。

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 64691    Accepted Submission(s): 24779

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3 olleh !dlrow m'I morf .udh I ekil .mca
Sample Output
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\\n' after the interger T, then you may use gets() to read a line and process it.
#include <iostream>
#include <stack>

using namespace std;

int main()
{
   cin.sync_with_stdio(false);
   cin.tie(nullptr);
   int n;
   char ch;
   cin>>n;
   getchar();
   while (n--)
   {
        stack<char> s;
        while (true)
        {
            ch=getchar();
            if(ch==' '||ch=='\\n'||ch==EOF)
            {
                while (!s.empty())
                {
                    cout<<s.top();
                    s.pop();
                }
                if(ch=='\\n'||ch==EOF)
                {
                    break;
                }
                cout<<' ';

            }else
            {
                s.push(ch);
            }
        }
        cout<<'\\n';
   }
   return 0;
}

以上是关于hdu1062 Text Reverse的主要内容,如果未能解决你的问题,请参考以下文章

J - Text Reverse HDU - 1062

hdu1062 Text Reverse

hdu1062 text reverse

Hdu 1062 Text Reverse

HDOJ/HDU 1062 Text Reverse(字符串翻转~)

HDU 1062 Text Reverse