1045. Favorite Color Stripe (30)-PAT甲级真题

Posted Keep--Silent

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1045. Favorite Color Stripe (30)-PAT甲级真题相关的知识,希望对你有一定的参考价值。

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤1e4) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:
For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:
7

题目的大概意思:给两个数组,从第二数组中选取一些数(尽可能地多),满足这些数形成的顺序和第一个数组一样。比如第一个数组:{2 3 1 5 6},那么第二个数组可以选取{2 2 3 1 1 5 6},满足顺序,而且最多个(7个)。

实际上,这是一道最长非递减子序列(一开始还真没看出来)。
把{2 3 1 5 6}的位置记录下来{1 2 3 4 5}。选取元素的时候,判断位置就好。
选取的话,参考博客https://blog.csdn.net/qq_45543594/article/details/118701440
在这里,我用map记录第一个数组每个数的位置。
第二个数组读入的时候,按最长非递减子序列构造vector<int>ans

#include <bits/stdc++.h>
using namespace std;
const int SIZE=10220;
int num[SIZE],t[SIZE];
vector<int>ans;
map<int,int>q;
map<int,int>::iterator it;
int main() {
	int n,m,k,i,j,x,pot;
	cin>>k;
	cin>>m;
	ans.push_back(0);
	for(j=1;j<=m;j++)cin>>x,q[x]=j;
	cin>>n;
	for(i=1;i<=n;i++){
		cin>>num[i];
		it=q.find(num[i]);
		if(it==q.end())continue;
		x=it->second;
		if(x>=ans[ans.size()-1])ans.push_back(x);
		else {
			*upper_bound(ans.begin(),ans.end(),x)=x;
		}
	}
	cout<<ans.size()-1<<endl;
	return 0;
}

以上是关于1045. Favorite Color Stripe (30)-PAT甲级真题的主要内容,如果未能解决你的问题,请参考以下文章

PAT 1045. Favorite Color Stripe (30)

1045. Favorite Color Stripe (30)-PAT甲级真题

PAT 1045 Favorite Color Stripe (30分) 动态规划

1045 Favorite Color Stripe (最长不下降子序列 LIS)

[pat]1045 Favorite Color Stripe

1045 Favorite Color Stripe(LIS解法)