POJ3370 UVA11237 HDU1808 Halloween treats鸽笼原理
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ3370 UVA11237 HDU1808 Halloween treats鸽笼原理相关的知识,希望对你有一定的参考价值。
Halloween treats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11017 Accepted: 3823 Special Judge
Description
Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year’s experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.
Your job is to help the children and present a solution.
Input
The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , … , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.
The last test case is followed by two zeros.
Output
For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print “no sweets” instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.
Sample Input
4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0
Sample Output
3 5
2 3 4
Source
问题链接:POJ3370 UVA11237 HDU1808 Halloween treats
问题简述:给定2个整数c和n (1 ≤ c ≤ n ≤ 100000),以及n个整数a1 , … , an (1 ≤ ai ≤ 100000 ),从n个整数中找出任意个数,其和为c的倍数。输出这些数的序号。
问题分析:
构造序列si=a1+a2+…+ai,若si为c的倍数则输出结果,若si和sj(满足si<sj)除以c其余数相同,则ai+1,…+aj为c的倍数。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* POJ3370 UVA11237 HDU1808 Halloween treats */
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 100000;
int a[N + 1], mod[N + 1];
int main()
{
int c, n;
while (~scanf("%d%d", &c, &n) && (c || n)) {
for (int i = 1; i <= n; i++) scanf("%d", &a[i]);
int sum = 0;
memset(mod, -1, sizeof mod);
for (int i = 1; i <= n; i++) {
if ((sum = (sum + a[i]) % c) == 0) {
for (int j = 1; j < i; j++)
printf("%d ", j);
printf("%d\\n", i);
break;
} else if (mod[sum] != -1) {
for (int j = mod[sum] + 1; j < i; j++)
printf("%d ", j);
printf("%d\\n", i);
break;
} else
mod[sum] = i;
}
}
return 0;
}
以上是关于POJ3370 UVA11237 HDU1808 Halloween treats鸽笼原理的主要内容,如果未能解决你的问题,请参考以下文章
2018 Spring Single Training B (uva 572,HihoCoder 1632,POJ 2387,POJ 2236,UVA 10054,HDU 2141)
POJ1420 HDU1659 UVA196 UVALive5606 SpreadsheetDFS
UVA121 POJ1319 HDU1621 Pipe Fitters计算几何