POJ1195 Mobile phones二维树状数组
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ1195 Mobile phones二维树状数组相关的知识,希望对你有一定的参考价值。
Mobile phones
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 25904 Accepted: 11812
Description
Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.
Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.
Input
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.
The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
Table size: 1 * 1 <= S * S <= 1024 * 1024
Cell value V at any time: 0 <= V <= 32767
Update amount: -32768 <= A <= 32767
No of instructions in input: 3 <= U <= 60002
Maximum number of phones in the whole table: M= 2^30
Output
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3
Sample Output
3
4
Source
IOI 2001
问题链接:POJ1195 Mobile phones
问题简述:(略)
问题分析:二维树状数组问题,按照题意给定的命令进行模拟操作即可。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* POJ1195 Mobile phones */
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1024 + 1;
int s, a[N][N];
inline int lowbit(int x) { return x & -x;}
int sum(int x, int y)
{
int ret = 0;
for (int i = x; i > 0; i -= lowbit(i))
for (int j = y; j > 0; j -= lowbit(j))
ret += a[i][j];
return ret;
}
void add(int x, int y, int d)
{
for (int i = x; i <= s; i += lowbit(i))
for (int j = y; j <= s; j += lowbit(j))
a[i][j] += d;
}
int main()
{
int op;
while (scanf("%d", &op) == 1) {
if (op == 0) {
scanf("%d", &s);
for (int i = 1; i <= s; i++)
for (int j = 1; j <= s; j++)
a[i][j] = 0;
} else if (op == 1) {
int x, y, a2;
scanf("%d%d%d", &x, &y, &a2);
add(x + 1, y + 1, a2);
} else if (op == 2) {
int l, b, r, t;
scanf("%d%d%d%d", &l, &b, &r, &t);
l++, b++, r++, t++;
printf("%d\\n", sum(r, t) - sum(r, b - 1) - sum(l - 1, t) + sum(l - 1, b - 1));
} else if (op == 3)
break;
}
return 0;
}
以上是关于POJ1195 Mobile phones二维树状数组的主要内容,如果未能解决你的问题,请参考以下文章
POJ 1195 Mobile phones (二维树状数组)