HDU1524 POJ2425 A Chess GameSG函数
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1524 POJ2425 A Chess GameSG函数相关的知识,希望对你有一定的参考价值。
A Chess Game
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3183 Accepted Submission(s): 1425
Problem Description
Let’s design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me… I will disturb the chesses and play it again.
Do you want to challenge me? Just write your program to show your qualification!
Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
Output
There is one line for each query, which contains a string “WIN” or “LOSE”. “WIN” means that the player taking the first turn can win the game according to a clever strategy; otherwise “LOSE” should be printed.
Sample Input
4
2 1 2
0
1 3
0
1 0
2 0 2
0
4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0
Sample Output
WIN
WIN
WIN
LOSE
WIN
Source
PKU Monthly
问题链接:HDU1524 POJ2425 A Chess Game
问题简述:(略)
问题分析:博弈的SG函数问题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* HDU1524 POJ2425 A Chess Game */
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1000 + 1;
int map[N][N], sg[N];
int getSG(int n)
{
if (sg[n] != -1) return sg[n];
if (map[n][0] == 0) return sg[n] = 0;
bool vis[N];
memset(vis, 0, sizeof vis);
for (int i = 1; i <= map[n][0]; i++)
vis[getSG(map[n][i])] = 1;
int i = 0;
while (vis[i]) i++;
return sg[n] = i;
}
int main()
{
int n, m;
while (~scanf("%d", &n)) {
for (int i = 0; i < n; i++) {
scanf("%d", &map[i][0]);
for (int j = 1; j <= map[i][0]; j++)
scanf("%d", &map[i][j]);
}
memset(sg, -1, sizeof sg);
while (~scanf("%d", &m) && m) {
int ans = 0, k;
for (int i = 0; i < m; i++) {
scanf("%d", &k);
ans ^= getSG(k);
}
puts(ans ? "WIN" : "LOSE");
}
}
return 0;
}
以上是关于HDU1524 POJ2425 A Chess GameSG函数的主要内容,如果未能解决你的问题,请参考以下文章