POJ2182 HDU2711 Lost Cows树状数组+线段树

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2182 HDU2711 Lost Cows树状数组+线段树相关的知识,希望对你有一定的参考价值。

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17113 Accepted: 10664

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1…N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

  • Line 1: A single integer, N

  • Lines 2…N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

  • Lines 1…N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

USACO 2003 U S Open Orange

问题链接POJ2182 HDU2711 Lost Cows
问题简述:(略)
问题分析:区间查询问题,用树状数组或线段树解决。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序(树状数组)如下:

/* POJ2182 HDU2711 Lost Cows */

#include <iostream>
#include <cstdio>

using namespace std;

const int N = 8000 + 1;
int n, tree[N], pre[N], ans[N];

inline int lowbit(int x) {return x & -x;}
void add(int x, int d) {while(x <= n) tree[x] += d, x += lowbit(x);}

int sum(int x)
{
    int sum = 0;
    while(x > 0) sum += tree[x], x -= lowbit(x);
    return sum;
}

int find(int x)
{
    int l = 1, r = n;
    while (l < r) {
        int mid = (l + r) >> 1;
        if (sum(mid) < x)
            l = mid + 1;
        else
            r = mid;
    }
    return l;
}

int main()
{
    while(~scanf("%d", &n)) {
        pre[1] = 0;
        for (int i = 2; i <= n; i++) scanf("%d", &pre[i]);

        for (int i = 1; i <= n; i++) tree[i] = lowbit(i);

        for (int i = n; i > 0; i--) {
            int p = find(pre[i] + 1);
            add(p, -1);
            ans[i] = p;
        }

        for (int i = 1; i <= n; i++)
            printf("%d\\n", ans[i]);
    }

    return 0;
}

AC的C++语言程序(线段树)如下:

/* POJ2182 HDU2711 Lost Cows */

#include <iostream>
#include <cstdio>

using namespace std;

const int N = 8000 + 1;
struct {
    int l, r, len;
} tree[4 * N];
int pre[N], ans[N];

void buildTree(int left, int right, int u)
{
    tree[u].l = left;
    tree[u].r = right;
    tree[u].len = right - left + 1;              //更新结点u的值
    if(left == right) return;
    buildTree(left, (left + right) >> 1, u << 1);    //递归左子树。
    buildTree(((left + right) >> 1) + 1, right, (u << 1) + 1);    //递归右子树。
}

int query(int u, int num)
{
    tree[u].len--;         // 对访问到的区间维护len。即把这个结点上牛的数量减去一。
    if (tree[u].l == tree[u].r) return tree[u].l;
    // 情况1:左子区间内牛的个数不够,则查询右子区间的左起第num - tree[u<<1].len个元素。
    if (tree[u << 1].len < num)
        return query((u << 1) + 1, num - tree[u << 1].len);
    // 情况2:左子区间内牛的个数足够,则依旧查询左子区间的左起第num个元素。
    else
        return query(u << 1, num);
}

int main()
{
    int n;
    while(~scanf("%d", &n)) {
        pre[1] = 0;
        for (int i = 2; i <= n; i++) scanf("%d", &pre[i]);

        buildTree(1, n, 1);
        for (int i = n; i >= 1; i--)
            ans[i] = query(1, pre[i] + 1);

        for (int i = 1; i <= n; i++)
            printf("%d\\n", ans[i]);
    }

    return 0;
}

以上是关于POJ2182 HDU2711 Lost Cows树状数组+线段树的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2182Lost Cows

POJ2182Lost Cows

POJ 2182 Lost Cows 巧妙解法

POJ2182 Lost Cows (树状数组+二分)

POJ2182:Lost Cows

18.10.15 POJ 2182 Lost Cows(线段树)