POJ2528 UVA10587 Mayor‘s posters线段树

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2528 UVA10587 Mayor‘s posters线段树相关的知识,希望对你有一定的参考价值。

Mayor’s posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 99829 Accepted: 28528

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source

Alberta Collegiate Programming Contest 2003.10.18

问题链接POJ2528 UVA10587 Mayor’s posters
问题简述:(略)
问题分析:线段树问题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2528 UVA10587 Mayor's posters */

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 2 * 1000000 + 1;
int n, cnt, tree[N], l[N], r[N], ans[N], vis[N];

void pushdown(int num)
{
    if(tree[num] != -1) {
        tree[num * 2]= tree[num];
        tree[num * 2 + 1]= tree[num];
        tree[num] = -1;
    }
}

void update(int num, int l, int r, int x, int y, int z)
{
    if (x <= l && r <= y) tree[num] = z;
    else {
        pushdown(num);
        int mid = (l + r) >> 1;
        if (x <= mid) update(num * 2, l, mid, x, y, z);
        if (y > mid) update(num * 2 + 1, mid + 1, r, x, y, z);
    }
}

void query(int num, int l, int r)
{
    if (tree[num] != -1) {
        if(vis[tree[num]] == 0) cnt++, vis[tree[num]] = 1;
    } else {
        if (l != r) {
            int mid = (l + r) >> 1;
            query(num * 2, l, mid);
            query(num * 2 + 1, mid + 1, r);
        }
    }
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--) {
        scanf("%d", &n);

        int k = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &l[i], &r[i]);
            ans[k++] = l[i];
            ans[k++] = r[i];
        }

        sort(ans, ans + k);

        k = unique(ans, ans + k) - ans;
        int end = k;
        for (int i = 1; i < end; i++)
            if (ans[i] != ans[i - 1] + 1)
                ans[k++] = ans[i - 1] + 1;

        sort(ans, ans + k);

        memset(tree, -1, sizeof tree);

        for (int i = 0; i < n; i++) {
            int left = lower_bound(ans, ans + k, l[i]) - ans;
            int right = lower_bound(ans, ans +k, r[i]) - ans;
            update(1, 0, k, left, right, i + 1);
        }

        memset(vis, 0, sizeof vis);
        cnt = 0;
        query(1, 0, k);

        printf("%d\\n", cnt);
    }

    return 0;
}

以上是关于POJ2528 UVA10587 Mayor‘s posters线段树的主要内容,如果未能解决你的问题,请参考以下文章

poj 2528 Mayor's posters

[POJ2528]Mayor's posters

poj~2528 Mayor's posters

Mayor's posters POJ - 2528

POJ-2528-Mayor's posters

poj2528 Mayor's posters 2011-12-20