POJ2609 Ferry LoadingDP
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2609 Ferry LoadingDP相关的知识,希望对你有一定的参考价值。
Ferry Loading
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1970 Accepted: 549 Special Judge
Description
Before bridges were common, ferries were used to transport cars across rivers. River ferries, unlike their larger cousins, run on a guide line and are powered by the river’s current. Two lanes of cars drive onto the ferry from one end, the ferry crosses the river, and the cars exit from the other end of the ferry.
The cars waiting to board the ferry form a single queue, and the operator directs each car in turn to drive onto the port (left) or starboard (right) lane of the ferry so as to balance the load. Each car in the queue has a different length, which the operator estimates by inspecting the queue. Based on this inspection, the operator decides which side of the ferry each car should board, and boards as many cars as possible from the queue, subject to the length limit of the ferry. Your job is to write a program that will tell the operator which car to load on which side so as to maximize the number of cars loaded.
Input
The first line of input contains a single integer between 1 and 100: the length of the ferry (in metres). For each car in the queue there is an additional line of input specifying the length of the car (in cm, an integer between 100 and 3000 inclusive). A final line of input contains the integer 0. The cars must be loaded in order, subject to the constraint that the total length of cars on either side does not exceed the length of the ferry. Subject to this constraint as many cars should be loaded as possible, starting with the first car in the queue and loading cars in order until no more can be loaded.
Output
The first line of outuput should give the number of cars that can be loaded onto the ferry. For each car that can be loaded onto the ferry, in the order the cars appear in the input, output a line containing “port” if the car is to be directed to the port side and “starboard” if the car is to be directed to the starboard side. If several arrangements of the cars meet the criteria above, any one will do.
Sample Input
50
2500
3000
1000
1000
1500
700
800
0
Sample Output
6
port
starboard
starboard
starboard
port
port
Source
问题链接:POJ2609 Ferry Loading
问题简述:(略)
问题分析:动态规划问题,不解释。
程序说明:测试数据有毒?
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* POJ2609 Ferry Loading */
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1000 + 1;
const int M = 10000 + 1;
int a[N], sum[N], dp[201][M], pre[201][M], where[N];
int main()
{
int len, n;
while (scanf("%d", &len) == 1) {
len *= 100;
sum[0] = 0;
n = 1;
while (~scanf("%d", &a[n]) && a[n]) {
sum[n] = sum[n - 1] + a[n];
n++;
}
n--;
memset(dp, 0, sizeof dp);
dp[0][0] = 1;
int maxcar = 0, maxlen;
for (int i = 1; i <= n; i++) {
for (int j = 0; j <= len; j++) {
if (j - a[i] >= 0 && dp[i - 1][j - a[i]]) {
dp[i][j] = 1;
pre[i][j] = 0; // left
}
if (sum[i] - j <= len && dp[i- 1][j]) {
dp[i][j] = 1;
pre[i][j] = 1; // right
}
if (dp[i][j])
maxcar = i, maxlen = j;
}
if (maxcar != i) break;
}
int i = maxcar, j = maxlen;
while (i) {
where[i] = pre[i][j];
if (pre[i][j] == 0) j -= a[i];
i--;
}
printf("%d\\n", maxcar);
for (int i = 1; i <= maxcar; i++)
puts(where[i] ? "starboard" : "port");
}
return 0;
}
以上是关于POJ2609 Ferry LoadingDP的主要内容,如果未能解决你的问题,请参考以下文章
使用 Vue3 + Element Plus + Go 重构 ferry 工单系统