POJ2704 HDU1208 LA3390 Pascal‘s Travels递推+记忆化搜索

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2704 HDU1208 LA3390 Pascal‘s Travels递推+记忆化搜索相关的知识,希望对你有一定的参考价值。

Pascal’s Travels
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5656 Accepted: 2538

Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.

Figure 1                               Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.
Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 263 paths for any board.

Sample Input

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

Sample Output

3
0
7

Hint

Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as long values in Java or long long values using the contest’s C/C++ compilers.

Source

Mid-Central USA 2005

问题链接POJ2704 HDU1208 LA3390 Pascal’s Travels
问题简述:给定一个棋盘,棋盘上的每个数字表示需要走几格,只能向下或向右走。问从左上角走到右下角有几种走法?
问题分析:一种方法是用递推实现,通常称为DP实现;另外一种方法是用DFS实现,用记忆化搜索来加快速度。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2704 HDU1208 LA3390 Pascal's Travels */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 34;
char b[N][N + 1];
long long dp[N][N];
int n;

int main()
{
    while (~scanf("%d", &n) && n != -1) {
        getchar();
        for (int i = 0; i < n; i++) {
            scanf("%s", b[i]);
            for (int j = 0; j < n; j++)
                b[i][j] -= '0';
        }

        memset(dp, 0, sizeof dp);
        dp[0][0] = 1;
        for (int i = 0; i < n; i++)
            for (int j = 0; j < n; j++)
                if (b[i][j]) {
                    if (i + b[i][j] < n)
                        dp[i + b[i][j]][j] += dp[i][j];
                    if (j + b[i][j] < n)
                        dp[i][j + b[i][j]] += dp[i][j];
                }

        printf("%lld\\n", dp[n - 1][n - 1]);
    }

    return 0;
}

AC的C++语言程序如下:

/* POJ2704 HDU1208 LA3390 Pascal's Travels */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int drow[] = {0, 1};
const int dcol[] = {1, 0};
const int N = 34;
char b[N][N + 1];
int vis[N][N];
long long dp[N][N];
int n;

long long dfs(int row, int col)
{
    if (row < 0 || row >= n || col < 0 || col >= n) return 0;
    if (vis[row][col]) return dp[row][col];
    vis[row][col] = 1;
    for (int i = 0; i < 2; i++)
        dp[row][col] += dfs(row + (b[row][col] - '0') * drow[i], col + (b[row][col] - '0') * dcol[i]);
    return dp[row][col];

}

int main()
{
    while (~scanf("%d", &n) && n != -1) {
        getchar();
        for (int i = 0; i < n; i++)
            scanf("%s", b[i]);

        memset(vis, 0, sizeof vis);
        memset(dp, 0, sizeof dp);
        vis[n - 1][n - 1] = 1;
        dp[n - 1][n - 1] = 1;

        printf("%lld\\n", dfs(0, 0));
    }

    return 0;
}

以上是关于POJ2704 HDU1208 LA3390 Pascal‘s Travels递推+记忆化搜索的主要内容,如果未能解决你的问题,请参考以下文章

HDU1416 POJ1078 UVA653 LA5507 GizilchDFS

POJ2033 LA3078 HDU1508 ZOJ2202 AlphacodeDFS+DP

POJ2142 LA3185 HDU1356 The Balance同余方程

POJ1323 LA2521 HDU1338 ZOJ1362 Game Prediction贪心

POJ2092 LA3157 HDU1347 ZOJ2250 Grandpa is Famous排序

UVA619 LA5465 POJ1312 HDU1314 ZOJ1272 Numerically Speaking大数+进制