poj 3255 Roadblocks

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 3255 Roadblocks相关的知识,希望对你有一定的参考价值。

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

Source

 
一个求次短路的问题,只需要记录到每个点的次短路就ok,然后用每次更新的最短路和次短路继续去更新他的邻接点。
代码:
技术分享图片
#include <cstdio>
#include <iostream>
#include <cstring>
#include <map>
#include <queue>
#define inf 0x3f3f3f3f
#define Max 200005
using namespace std;
typedef pair<int,int> p;
int n,r;
int fir[Max],nex[Max],u[Max],v[Max],w[Max];
int dis[5001],sdis[5001];

int main()
{
    scanf("%d%d",&n,&r);
    memset(fir,-1,sizeof(fir));
    memset(dis,inf,sizeof(dis));
    memset(sdis,inf,sizeof(sdis));
    for(int i = 0;i < r;i ++)
    {
        scanf("%d%d%d",&u[i],&v[i],&w[i]);
        u[i + r] = v[i];
        v[i + r] = u[i];
        w[i + r] = w[i];
        nex[i] = fir[u[i]];
        fir[u[i]] = i;
        nex[i + r] = fir[u[i + r]];
        fir[u[i + r]] = i + r;
    }
    dis[1] = 0;
    priority_queue<p,vector<p>,greater<p> >q;
    q.push(p(0,1));
    while(!q.empty())
    {
        p s = q.top();
        q.pop();
        if(sdis[s.second] < s.first)continue;
        int k = fir[s.second];
        while(k != -1)
        {
            int d = w[k] + s.first;
            if(d < dis[v[k]])
            {
                q.push(p(d,v[k]));
                swap(d,dis[v[k]]);
            }
            if(d < sdis[v[k]])
            {
                q.push(p(d,v[k]));
                sdis[v[k]] = d;
            }
            k = nex[k];
        }
    }
    printf("%d",sdis[n]);
}
View Code

 

以上是关于poj 3255 Roadblocks的主要内容,如果未能解决你的问题,请参考以下文章

POJ-3255-Roadblocks POJ-Dijkstra+邻接表

POJ 3255 Roadblocks

cogs 315. [POJ3255] 地砖RoadBlocks

POJ 3255 Roadblocks (次短路模板)

poj 3255 Roadblocks

POJ3255-Roadblocks(最短路)