POJ 3255Roadblocks (Dijkstra求次短路)

Posted Farewell

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 3255Roadblocks (Dijkstra求次短路)相关的知识,希望对你有一定的参考价值。

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and R
Lines 2.. R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

题意:

求1到N的次短路(次短的路径)。

题解:

到某个顶点v的次短路有两种情况:1.到其他某个点的次短路再加上u->v的边
2.到u的次短路再加上u->v的边。因此需要求出到所有顶点的最短路和次短路。

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
const int maxn=5005,INF=0x3f3f3f3f;
struct edge
{
    int to,cost;
    edge(int to,int c):to(to),cost(c){}
};
vector<edge> G[maxn];
int dist[maxn];
int dist2[maxn];
int n,m;
typedef pair<int,int> P;
void dijkstra(int s)
{
    priority_queue<P,vector<P>,greater<P> > que;
    fill(dist,dist+maxn,INF);
    fill(dist2,dist2+maxn,INF);
    dist[s]=0;
    que.push(P(0,s));
    while(!que.empty())
    {
        P p=que.top();
        que.pop();
        int v=p.second,d=p.first;
        if(dist2[v]<d)
            continue;
        for(int i=0;i<G[v].size();i++)
        {
            edge &e=G[v][i];
            int d2=d+e.cost;
            if(dist[e.to]>d2)
            {
                swap(dist[e.to],d2);
                que.push(P(dist[e.to],e.to));
            }
            if(dist2[e.to]>d2&&dist[e.to]<d2)
            {
                dist2[e.to]=d2;
                que.push(P(dist2[e.to],e.to));
            }
        }
    }
    cout<<dist2[n]<<endl;
}
int main()
{
    cin>>n>>m;
    for(int i=0;i<m;i++)
    {
        int u,v,c;
        cin>>u>>v>>c;
        G[u].push_back(edge(v,c));
        G[v].push_back(edge(u,c));
    }
    dijkstra(1);
    return 0;
}

以上是关于POJ 3255Roadblocks (Dijkstra求次短路)的主要内容,如果未能解决你的问题,请参考以下文章

cogs 315. [POJ3255] 地砖RoadBlocks

POJ 3255 Roadblocks (次短路模板)

poj 3255 Roadblocks

POJ3255-Roadblocks(最短路)

poj 3255 Roadblocks

poj3255 Roadblocks