POJ3255 Roadblocks 次短路

Posted zhchoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ3255 Roadblocks 次短路相关的知识,希望对你有一定的参考价值。

Roadblocks
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7760   Accepted: 2848

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 
Lines 2..R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

Source

堆优化版本号的Dijkstra

#include <stdio.h>
#include <string.h>
#include <queue>
#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

#define maxn 5010
#define maxm 200010
#define inf 0x3f3f3f3f

int N, R, head[maxn], id;
struct Node {
    int v, w, next;
} E[maxm];
int dis[maxn], dis2[maxn];
typedef pair<int, int> P;


void addEdge(int u, int v, int w) {
    E[id].v = v; E[id].w = w;
    E[id].next = head[u];
    head[u] = id++;
}

void getMap() {
    int a, b, c; id = 0;
    memset(head, -1, sizeof(int) * (N + 1));
    while(R--) {
        scanf("%d%d%d", &a, &b, &c);
        addEdge(a, b, c);
        addEdge(b, a, c);
    }
}

void Dijkstra() {
    int u = 1, v, d, d2, i;
    P now;
    for(i = 1; i <= N; ++i) {
        dis[i] = dis2[i] = inf;
    }
    priority_queue<P, vector<P>, greater<P> > pq;
    dis[u] = 0;
    pq.push(P(0, u));
    while(!pq.empty()) {
        now = pq.top(); pq.pop();
        d = now.first;
        u = now.second;
        if(d > dis2[u]) continue;

        for(i = head[u]; i != -1; i = E[i].next) {
            v = E[i].v;
            d2 = d + E[i].w;
            if(d2 < dis[v]) {
                swap(dis[v], d2);
                pq.push(P(dis[v], v));
            }
            if(dis2[v] > d2 && dis[v] < d2) {
                dis2[v] = d2;
                pq.push(P(dis2[v], v));
            }
        }
    }
    printf("%d\n", dis2[N]);
}

int main() {
    while(scanf("%d%d", &N, &R) == 2) {
        getMap();
        Dijkstra();
    }
    return 0;
}





以上是关于POJ3255 Roadblocks 次短路的主要内容,如果未能解决你的问题,请参考以下文章

POJ3255 Roadblocks 次短路

POJ3255Roadblocks[次短路]

POJ3255 Roadblocks [Dijkstra,次短路]

POJ-3255 Roadblocks---Dijkstra队列优化+次短路

POJ 3255Roadblocks (Dijkstra求次短路)

POJ-3255-Roadblocks(次短路的另一种求法)