POJ.1852.Ants(C++)

Posted ~星常明~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ.1852.Ants(C++)相关的知识,希望对你有一定的参考价值。

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

 

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

 

4 8
38 207

翻译

分析:

首先对于最短时间,所有蚂蚁都朝向最近的端点时,时间最短。此过程没有发生相遇额情况。

下面考虑蚂蚁相遇的情况,当蚂蚁相遇后可以认为是保持原样前行。因为当蚂蚁相遇时,最长时间依旧是距离端点最长的蚂蚁所行走的时间。因此,只要求蚂蚁到竿子端点的最大距离。

#include <iostream>
using namespace std;

#define maxn 1000100
int ant[maxn];

void solve(int L,int n,int x[]);

int main()

	int num;					//案例数 
	cin >>num;
	while(num--)
	int L,n,i,j;					//L为竿子长度,n为蚂蚁数 
	cin >>L >>n;
	for(i=0;i<n;i++)
		cin >>ant[i];
	solve(L,n,ant);
	
	 return 0;


void solve(int L,int n,int x[])

	int mint=0,maxt=0;
	int i;
	for(i=0;i<n;i++)
	
		mint=max(mint,min(x[i],L-x[i]));
	
	
	for(i=0;i<n;i++)
	
		maxt=max(maxt,max(x[i],L-x[i]));
	
	cout <<mint <<" " <<maxt <<endl;


/*输入样例
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
*/ 

以上是关于POJ.1852.Ants(C++)的主要内容,如果未能解决你的问题,请参考以下文章

POJ.1852.Ants(C++)

POJ.1852.Ants(C++)

POJ 1852 Ants

POJ 1852 Ants

POJ 1852 Ants

POJ 1852 Ants