1040
Posted tookkke
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1040相关的知识,希望对你有一定的参考价值。
As Easy As A+B
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 53206 Accepted Submission(s): 22844
Problem Description These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
Input Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
Output For each case, print the sorting result, and one line one case.
Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
说是水题,结果真是水题(#喷水),这排序太直接。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define MAXN 1010
using namespace std;
int n;
int kkke[MAXN];
int main()
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
int t;
scanf("%d",&t);
while(t--)
scanf("%d",&n);
for(int i=0;i<n;i++)scanf("%d",&kkke[i]);
sort(kkke,kkke+n);
printf("%d",kkke[0]);
for(int i=1;i<n;i++)printf(" %d",kkke[i]);
putchar('\\n');
return 0;
以上是关于1040的主要内容,如果未能解决你的问题,请参考以下文章