蓝桥杯历届试题 带分数

Posted 蒙面侠1024

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了蓝桥杯历届试题 带分数相关的知识,希望对你有一定的参考价值。

问题描述

100 可以表示为带分数的形式:100 = 3 + 69258 / 714。

还可以表示为:100 = 82 + 3546 / 197。

注意特征:带分数中,数字1~9分别出现且只出现一次(不包含0)。

类似这样的带分数,100 有 11 种表示法。

输入格式

从标准输入读入一个正整数N (N<1000*1000)

输出格式

程序输出该数字用数码1~9不重复不遗漏地组成带分数表示的全部种数。

注意:不要求输出每个表示,只统计有多少表示法!

样例输入1

100

样例输出1

11

样例输入2

105

样例输出2

6

1-9进行全排列,再进行分段,分为三段,将三段进行运算。

import java.util.Scanner;

public class Main {
	static int N=10;
	static int[] num=new int[N];
	static boolean[] used=new boolean[N];
	static int target;
	static int cnt=0;
	
	static int calc(int l,int r) {
		int res=0;
		for(int i=l;i<=r;i++)
			res=res*10+num[i];
		return res;
	}
	
	static void dfs(int u) {
		if (u==9) {
			 for(int i = 0; i < 7; i++)
		            for(int j = i + 1; j < 8; j++){
		                int a = calc(0, i);
		                int b = calc(i + 1, j);
		                int c = calc(j + 1, 8);
		                if(a * c + b == c * target) 
		                	cnt++;
		            }
		        return;
		}
		//全排列
		for(int i=1;i<=9;i++) {
			if(!used[i]) {
				used[i]=true;
				num[u]=i;
				dfs(u+1);
				used[i]=false;
			}
		}
	}
	
	public static void main(String[] args) {
		Scanner in=new Scanner(System.in);
		target=in.nextInt();
		dfs(0);
		System.out.println(cnt);
}
}

以上是关于蓝桥杯历届试题 带分数的主要内容,如果未能解决你的问题,请参考以下文章

蓝桥杯历届试题 带分数

蓝桥杯 - 带分数 (DFS)

蓝桥杯历届试题 正则问题(非dfs解决)

算法笔记_108:第四届蓝桥杯软件类省赛真题(JAVA软件开发本科A组)试题解答

蓝桥杯——根据手册写底层

[蓝桥杯]带分数