[PTA]6-13 折半查找

Posted Spring-_-Bear

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]6-13 折半查找相关的知识,希望对你有一定的参考价值。

给一个严格递增数列,函数int Search_Bin(SSTable T, KeyType k)用来二分地查找k在数列中的位置。

函数接口定义:

int  Search_Bin(SSTable T, KeyType k)

其中T是有序表,k是查找的值。

裁判测试程序样例:

#include <iostream>
using namespace std;

#define MAXSIZE 50
typedef int KeyType;

typedef  struct                     
{ KeyType  key;                                             
} ElemType;  

typedef  struct
{ ElemType  *R; 
  int  length;
} SSTable;                      

void  Create(SSTable &T)
{ int i;
  T.R=new ElemType[MAXSIZE+1];
  cin>>T.length;
  for(i=1;i<=T.length;i++)
     cin>>T.R[i].key;   
}

int  Search_Bin(SSTable T, KeyType k);

int main () 
{  SSTable T;  KeyType k;
   Create(T);
   cin>>k;
   int pos=Search_Bin(T,k);
   if(pos==0) cout<<"NOT FOUND"<<endl;
   else cout<<pos<<endl;
   return 0;
}

/* 请在这里填写答案 */

输入格式:

第一行输入一个整数n,表示有序表的元素个数,接下来一行n个数字,依次为表内元素值。 然后输入一个要查找的值。

输出格式:

输出这个值在表内的位置,如果没有找到,输出"NOT FOUND"。

输入样例:

5
1 3 5 7 9
7

输出样例:

4

输入样例:

5
1 3 5 7 9
10

输出样例:

NOT FOUND
  • 提交结果:

在这里插入图片描述

  • 源码:
#include <iostream>
using namespace std;

#define MAXSIZE 50
typedef int KeyType;

typedef  struct
{
    KeyType  key;
} ElemType;

typedef  struct
{
    ElemType* R;
    int  length;
} SSTable;

void  Create(SSTable& T)
{
    int i;
    T.R = new ElemType[MAXSIZE + 1];
    cin >> T.length;
    for (i = 1; i <= T.length; i++)
        cin >> T.R[i].key;
}

int  Search_Bin(SSTable T, KeyType k);

int main()
{
    SSTable T;  KeyType k;
    Create(T);
    cin >> k;
    int pos = Search_Bin(T, k);
    if (pos == 0) cout << "NOT FOUND" << endl;
    else cout << pos << endl;
    return 0;
}

/* 请在这里填写答案 */
int  Search_Bin(SSTable T, KeyType k)
{
    KeyType low = 0;
    KeyType up = T.length;
    KeyType mid = (low + up) / 2;

    while (low <= up)
    {
        if (T.R[mid].key == k)          // 成功找到k
        {
            return mid;
        }
        else if (T.R[mid].key < k)      // k位于后半区间,下限后移
        {
            low = mid + 1;
        }
        else                            // k位于前半区间,上限前移
        {
            up = mid - 1;
        }
        
        mid = (low + up) / 2;
    }

    return 0;
}

以上是关于[PTA]6-13 折半查找的主要内容,如果未能解决你的问题,请参考以下文章

C语言折半查找法详细代码(假如有10个已排好序的数)

折半查找的概念及实现代码

C语言折半查找法

C++折半查找法

c语言编程实现“折半查找”的过程。

PTA乙级 (1049 数列的片段和 (20分))