UVA10912 Simple Minded HashingDP

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA10912 Simple Minded HashingDP相关的知识,希望对你有一定的参考价值。

All of you know a bit or two about hashing. It involves mapping an element into a numerical value using some mathematical function. In this problem we will consider a very ‘simple minded hashing’. It involves assigning numerical value to the alphabets and summing these values of the characters.
    For example, the string “acm” is mapped to 1 + 3 + 13 = 17. Unfortunately, this method does not give one-to-one mapping. The string “adl” also maps to 17 (1 + 4 + 12). This is called collision.
    In this problem you will have to find the number of strings of length L, which maps to an integer S, using the above hash function. You have to consider strings that have only lowercase letters in strictly ascending order.
    Suppose L = 3 and S = 10, there are 4 such strings.

  1. abg
  2. acf
  3. ade
  4. bce

    “agb” also produces 10 but the letters are not strictly in ascending order.
    “bh” also produces 10 but it has 2 letters.
Input
There will be several cases. Each case consists of 2 integers L and S (0 < L, S < 10000). Input is terminated with 2 zeros.
Output
For each case, output ‘Case#:’ where # is replaced by case number. Then output the result. Follow the sample for exact format. The result will fit in 32 signed integers.
Sample Input
3 10
2 3
0 0
Sample Output
Case 1: 4
Case 2: 1

问题链接UVA10912 Simple Minded Hashing
问题简述:(略)
问题分析:动态规划问题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10912 Simple Minded Hashing */

#include <bits/stdc++.h>

using namespace std;

const int M = 26;
const int N = 10000;
int dp[M + 1][M + 1][N + 1], sum[M + 1][N + 1];

void init()
{
    memset(dp, 0, sizeof dp);
    memset(sum, 0, sizeof sum);
    dp[0][0][0] = 1;
    for (int i = 1; i <= M; i++)
        for (int k = 1; k <= i * M; k ++)
            for (int j = 1; j <= min(k, M); j++) {
                for (int m = 0; m < j; m++)
                    dp[i][j][k] += dp[i - 1][m][k - j];
                sum[i][k] += dp[i][j][k];
            }
}

int main()
{
    init();

    int l, s, caseno = 0;
    while (scanf("%d%d", &l, &s) == 2 && (l || s))
        printf("Case %d: %d\\n", ++caseno, sum[min(l, M)][s]);

    return 0;
}

以上是关于UVA10912 Simple Minded HashingDP的主要内容,如果未能解决你的问题,请参考以下文章

UVA11565 Simple Equations数学+暴力

UVA11532 Simple Adjacency Maximization位运算

UVA12253 简单加密法 Simple Encryption

The Product-Minded Software Engineer

UVA 10522 Height to Area(知三角形三高求面积)

RocketMq: Windows环境-单机部署和多种主从集群场景部署