UVA10003 Cutting SticksDP

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA10003 Cutting SticksDP相关的知识,希望对你有一定的参考价值。

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.
    It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.
    Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made.
    The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.
    An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.
Sample Input
100
3
25 50 75
10
4
4 5 7 8
0
Sample Output
The minimum cutting is 200.
The minimum cutting is 22.

问题链接UVA10003 Cutting Sticks
问题简述:(略)
问题分析:动态规划问题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10003 Cutting Sticks */

#include <bits/stdc++.h>

using namespace std;

const int INF = 0x3F3F3F3F;
const int N = 50 + 1;
int a[N], dp[N][N];

int main()
{
    int l, n;
    while (scanf("%d", &l) == 1 && l) {
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        a[++n] = l;

        memset(dp, 0, sizeof dp);
        for (int i = 2; i <= n; i++)
            for (int j = 0, k = i + j; k <= n; j++, k++) {
                int minv = INF;
                for (int m = j + 1; m < k; m++) {
                    int t = dp[j][m] + dp[m][k] + a[k] - a[j];
                    minv = min(minv, t);
                }
                dp[j][k] = minv;
            }

        printf("The minimum cutting is %d.\\n", dp[0][n]);
    }

    return 0;
}

以上是关于UVA10003 Cutting SticksDP的主要内容,如果未能解决你的问题,请参考以下文章

UVA-10003 Cutting Sticks (区间DP)

uva 10003 Cutting Sticks 区间dp

UVA10003 Cutting Sticks

UVA - 10003 Cutting Sticks(动态规划)

Cutting Sticks UVA - 10003

UVA 10003 Cutting Sticks 区间DP