UVA10325 The LotteryGCD+LCM

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA10325 The LotteryGCD+LCM相关的知识,希望对你有一定的参考价值。

The Sports Association of Bangladesh is in great problem with their latest lottery ‘Jodi laiga Jai’. There are so many participants this time that they cannot manage all the numbers. In an urgent meeting they have decided that they will ignore some numbers. But how they will choose those unlucky numbers!!! Mr. NondoDulal who is very interested about historic problems proposed a scheme to get free from this problem.
    You may be interested to know how he has got this scheme. Recently he has read the Joseph’s problem.
    There are N tickets which are numbered from 1 to N. Mr. Nondo will choose M random numbers and then he will select those numbers which is divisible by at least one of those M numbers. The numbers which are not divisible by any of those M numbers will be considered for the lottery.
    As you know each number is divisible by 1. So Mr. Nondo will never select 1 as one of those M numbers. Now given N, M and M random numbers, you have to find out the number of tickets which will be considered for the lottery.
Input
Each input set starts with two Integers N (10 ≤ N < 231) and M (1 ≤ M ≤ 15). The next line will contain M positive integers each of which is not greater than N.
    Input is terminated by EOF.
Output
Just print in a line out of N tickets how many will be considered for the lottery.
Sample Input
10 2
2 3
20 2
2 4
Sample Output
3
10

问题链接UVA10325 The Lottery
问题简述:给定整数n和m,以及m个正整数,求1~n中不能被这m个数字整除的数的个数?
问题分析:数论问题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10325 The Lottery */

#include <bits/stdc++.h>

using namespace std;

const int M = 15;
int a[M];

inline long long LCM(long long a, long long b)
{
    return a / __gcd(a, b) * b;
}

int main()
{
    int n, m;
    while (scanf("%d%d", &n, &m) == 2) {
        for (int i = 0; i < m; i++)
            scanf("%d", &a[i]);

        int e = 1 << m, ans = n;
        for (int i = 1; i < e; i++) {
            long long lcm = 1LL;
            int cnt = 0;
            for (int j = 0; j < m; j++)
                if (i & (1 << j)) {
                    lcm = LCM(lcm, a[j]);
                    cnt++;
                }
            if (cnt & 1) ans -= n / lcm;
            else ans += n / lcm;
        }

        printf("%d\\n", ans);
    }

    return 0;
}

以上是关于UVA10325 The LotteryGCD+LCM的主要内容,如果未能解决你的问题,请参考以下文章

uva10325(容斥原理)

UVA11077 Find the Permutations

UVA3942 Remember the Word

[UVa-437] The Tower of Babylon

UVA 1640 The Counting Problem

UVA10917 Walk Through the Forest