UVA10934 Dropping water balloonsDP
Posted 海岛Blog
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA10934 Dropping water balloonsDP相关的知识,希望对你有一定的参考价值。
It’s frosh week, and this year your friends have decided that they would initiate the new computer science students by dropping water balloons on them. They’ve filled up a large crate of identical water balloons, ready for the event. But as fate would have it, the balloons turned out to be rather tough, and can be dropped from a height of several stories without bursting!
So your friends have sought you out for help. They plan to drop the balloons from a tall building on campus, but would like to spend as little effort as possible hauling their balloons up the stairs, so they would like to know the lowest floor from which they can drop the balloons so that they do burst.
You know the building has n floors, and your friends have given you k identical balloons which you may use (and break) during your trials to find their answer. Since you are also lazy, you would like to determine the minimum number of trials you must conduct in order to determine with absolute certainty the lowest floor from which you can drop a balloon so that it bursts (or in the worst case, that the balloons will not burst even when dropped from the top floor). A trial consists of dropping a balloon from a certain floor. If a balloon fails to burst for a trial, you can fetch it and use it again for another trial.
Input
The input consists of a number of test cases, one case per line. The data for one test case consists of two numbers k and n, 1 ≤ k ≤ 100 and a positive n that fits into a 64 bit integer (yes, it’s a very tall building). The last case has k = 0 and should not be processed.
Output
For each case of the input, print one line of output giving the minimum number of trials needed to solve the problem. If more than 63 trials are needed then print ‘More than 63 trials needed.’ instead of the number.
Sample Input
2 100
10 786599
4 786599
60 1844674407370955161
63 9223372036854775807
0 0
Sample Output
14
21
More than 63 trials needed.
61
63
问题链接:UVA10934 Dropping water balloons
问题简述:给定n个气球和大楼的高度,求最少试验几次能测出气球最高在哪一层掉下来不破。
问题分析:经典的DP问题。
dp[i][j]表示用i个气球,测试出j高的楼。
状态转换方程如下:
dp[i][j] = 1
dp[i][j] = dp[i - 1][j - 1] + dp[i][j - 1] + 1
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C++语言程序如下:
/* UVA10934 Dropping water balloons */
#include <bits/stdc++.h>
using namespace std;
typedef unsigned long long ULL;
const int K = 100, B = 64;
ULL dp[K + 1][B];
void init()
{
for (int i = 1; i <= K; i++)
for (int j = 1; j < B; j++)
if (j == 1) dp[i][j] = 1;
else dp[i][j] = dp[i - 1][j - 1] + dp[i][j - 1] + 1;
}
int main()
{
init();
int k, i;
ULL n;
while (~scanf("%d%llu", &k, &n) && k) {
for (i = 1; i < B; i++)
if (dp[k][i] >= n) break;
if (i >= B) puts("More than 63 trials needed.");
else printf("%d\\n", i);
}
return 0;
}
以上是关于UVA10934 Dropping water balloonsDP的主要内容,如果未能解决你的问题,请参考以下文章
Dropping water balloons UVA - 10934(递推)
UVA10934 Dropping water balloons
uva 10934 Dropping water balloons
10934 - Dropping water balloons(DP)