[PAT乙级]1043 输出PATest
Posted Wecccccccc
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PAT乙级]1043 输出PATest相关的知识,希望对你有一定的参考价值。
给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest… 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
redlesPayBestPATTopTeephpereatitAPPT
输出样例:
PATestPATestPTetPTePePee
代码如下:
#include <iostream>
#include <string>
using namespace std;
const int N = 10;
int cnt[N];
char c[] = { 'P','A','T','e','s','t' };
int main()
{
string str;
cin >> str;
for (int i = 0; i < str.length(); i++)
{
if (str[i] == 'P') cnt[0]++;
else if (str[i] == 'A') cnt[1]++;
else if (str[i] == 'T') cnt[2]++;
else if (str[i] == 'e') cnt[3]++;
else if (str[i] == 's') cnt[4]++;
else if (str[i] == 't') cnt[5]++;
}
while (cnt[0] || cnt[1] || cnt[2] || cnt[3] || cnt[4] || cnt[5])
{
for (int i = 0; i < 6; i++)
{
if (cnt[i])
{
cout << c[i];
cnt[i]--;
}
}
}
return 0;
}
以上是关于[PAT乙级]1043 输出PATest的主要内容,如果未能解决你的问题,请参考以下文章