[PTA]6-9 统计个位数字

Posted Spring-_-Bear

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]6-9 统计个位数字相关的知识,希望对你有一定的参考价值。

本题要求实现一个函数,可统计任一整数中某个位数出现的次数。例如-21252中,2出现了3次,则该函数应该返回3。

函数接口定义:

int Count_Digit ( const int N, const int D );

其中N和D都是用户传入的参数。N的值不超过int的范围;D是[0, 9]区间内的个位数。函数须返回N中D出现的次数。

裁判测试程序样例:

#include <stdio.h>

int Count_Digit ( const int N, const int D );

int main()
{
    int N, D;

    scanf("%d %d", &N, &D);
    printf("%d\\n", Count_Digit(N, D));
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

-21252 2

输出样例:

3
  • 提交结果:

在这里插入图片描述

  • 源码:
#include <stdio.h>

int Count_Digit(const int N, const int D);

int main()
{
    int N, D;

    scanf("%d %d", &N, &D);
    printf("%d\\n", Count_Digit(N, D));
    return 0;
}

/* 你的代码将被嵌在这里 */
int Count_Digit(const int N, const int D)
{
    int count = 0;
    // N为不可变的变量,故赋值给n
    int n;

    // 处理保证n始终是整数
    if (N < 0)
    {
        n = -N;
    }
    else
    {
        n = N;
    }

    if (N == 0 && D == 0)
    {
        count = 1;
    }

    while (n != 0)
    {
        int lastNumber = n % 10;

        if (lastNumber == D)
        {
            count++;
        }

        n /= 10;
    }

    return count;
}

以上是关于[PTA]6-9 统计个位数字的主要内容,如果未能解决你的问题,请参考以下文章

6-9 统计个位数字 (15 分)

题解PTA团体程序设计天梯赛L1-003 个位数统计 (15 分) Go语言|Golang

[PTA]实验6-9 统计一行文本的单词个数

[PTA]习题7-2 求一批整数中出现最多的个位数字

PTA-----求一批整数中出现最多的个位数字

[PTA]实验2-1-7 整数152的各位数字