[PTA]实验10-1 圆形体体积计算器

Posted Spring-_-Bear

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验10-1 圆形体体积计算器相关的知识,希望对你有一定的参考价值。

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

  • 球体体积 V=4/3πr3,其中r是球体半径。
  • 圆柱体体积 V=πr2h,其中r是底圆半径,h是高。
  • 圆锥体体积 V=1/3πr2h,其中r是底圆半径,h是高。

输入格式:

在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
然后从标准输入读进一个整数指令。

输出格式:

如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4 3
0

输出样例:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
  • 提交结果:

在这里插入图片描述

  • 源码:
#include<stdio.h>

#define PI 3.1415926535		 // 若PI精度过低,则提交不能通过

void cal_Ball(void);		// 球体体积
void cal_Cylinder(void);	// 圆柱体体积
void cal_Cone(void);		// 圆锥体体积

int main(void)
{
	int choice;

	while (1)
	{
		printf("1-Ball\\n");
		printf("2-Cylinder\\n");
		printf("3-Cone\\n");
		printf("other-Exit\\n");
		printf("Please enter your command:\\n");
		scanf("%d", &choice);

		if (choice == 1)
		{
			cal_Ball();
		}
		else if (choice == 2)
		{
			cal_Cylinder();
		}
		else if (choice == 3)
		{
			cal_Cone();
		}
		else
		{
			break;
		}
	}

	return 0;
}

// 球体体积
void cal_Ball(void)
{
	double r;

	printf("Please enter the radius:\\n");
	scanf("%lf", &r);

	printf("%.2f\\n", 4.0 / 3 * PI * r * r * r);
}

// 圆柱体体积
void cal_Cylinder(void)
{
	double r, h;

	printf("Please enter the radius and the height:\\n");
	scanf("%lf %lf", &r, &h);


	printf("%.2f\\n", PI * r * r * h);
}

// 圆锥体体积
void cal_Cone(void)
{
	double r, h;

	printf("Please enter the radius and the height:\\n");
	scanf("%lf %lf", &r, &h);

	printf("%.2f\\n", 1.0 / 3 * PI * r * r * h);
}

以上是关于[PTA]实验10-1 圆形体体积计算器的主要内容,如果未能解决你的问题,请参考以下文章

实验10-1 圆形体体积计算器 (20分)

PTA ----- 圆形体体积计算器

五 PTA结构体实验

PTA实验作业(结构体)

-----污染体的采集“管道”须要的体积-----

[PTA]实验9-4 计算两个复数之积