[PTA]6-8 简单阶乘计算
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]6-8 简单阶乘计算相关的知识,希望对你有一定的参考价值。
本题要求实现一个计算非负整数阶乘的简单函数。
函数接口定义:
int Factorial( const int N );
其中N是用户传入的参数,其值不超过12。如果N是非负整数,则该函数必须返回N的阶乘,否则返回0。
裁判测试程序样例:
#include <stdio.h>
int Factorial( const int N );
int main()
{
int N, NF;
scanf("%d", &N);
NF = Factorial(N);
if (NF) printf("%d! = %d\\n", N, NF);
else printf("Invalid input\\n");
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
5
输出样例:
5! = 120
- 提交结果:
- 源码:
#include <stdio.h>
int Factorial(const int N);
int main()
{
int N, NF;
scanf("%d", &N);
NF = Factorial(N);
if (NF) printf("%d! = %d\\n", N, NF);
else printf("Invalid input\\n");
return 0;
}
/* 你的代码将被嵌在这里 */
int Factorial(const int N)
{
// 0!= 1
int result = 1;
// 负数没有阶乘
if (N < 0)
{
result = 0;
}
else
{
for (int i = 1; i <= N; i++)
{
result *= i;
}
}
return result;
}
以上是关于[PTA]6-8 简单阶乘计算的主要内容,如果未能解决你的问题,请参考以下文章