[PTA]6-2 多项式求值
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]6-2 多项式求值相关的知识,希望对你有一定的参考价值。
本题要求实现一个函数,计算阶数为n,系数为a[0] … a[n]的多项式f(x)=∑ni=0(a[i]xi) 在x点的值。
函数接口定义:
double f( int n, double a[], double x );
其中n是多项式的阶数,a[]中存储系数,x是给定点。函数须返回多项式f(x)的值。
裁判测试程序样例:
#include <stdio.h>
#define MAXN 10
double f( int n, double a[], double x );
int main()
{
int n, i;
double a[MAXN], x;
scanf("%d %lf", &n, &x);
for ( i=0; i<=n; i++ )
scanf(“%lf”, &a[i]);
printf("%.1f\\n", f(n, a, x));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
2 1.1
1 2.5 -38.7
输出样例:
-43.1
- 提交结果:
- 源码:
#include <stdio.h>
#include<math.h>
#define MAXN 10
double f(int n, double a[], double x);
int main()
{
int n, i;
double a[MAXN], x;
scanf("%d %lf", &n, &x);
for (i = 0; i <= n; i++)
scanf("%d %lf", &a[i]);
printf("%.1f\\n", f(n, a, x));
return 0;
}
/* 你的代码将被嵌在这里 */
double f(int n, double a[], double x)
{
double sum = 0;
for (int i = 0; i <= n; i++)
{
// sum = a[0]*x⁰ + a[1]*x¹ + ···
sum += a[i] * pow(x, i);
}
return sum;
}
以上是关于[PTA]6-2 多项式求值的主要内容,如果未能解决你的问题,请参考以下文章