[PTA]实验7-3-2 查找指定字符
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验7-3-2 查找指定字符相关的知识,希望对你有一定的参考价值。
本题要求编写程序,从给定字符串中查找某指定的字符。
输入格式:
输入的第一行是一个待查找的字符。第二行是一个以回车结束的非空字符串(不超过80个字符)。
输出格式:
如果找到,在一行内按照格式“index = 下标”输出该字符在字符串中所对应的最大下标(下标从0开始);否则输出"Not Found"。
输入样例1:
m
programming
输出样例1:
index = 7
输入样例2:
a
1234
输出样例2:
Not Found
- 提交结果:
- 源码:
#include<stdio.h>
#include<string.h>
int main(void)
{
int index;
char ch, string[81]; //字符串最长为80,需要存字符串结束标志符'\\0',故长度为81
ch = getchar(); //需要查找的字符
getchar(); //避免string字符串的第一个元素string[0]总为'\\n'
gets(string); //获得字符串,其最后一个字符为'\\0'
index = -1;
for (int i = 0; string[i] != '\\0'; i++)
{
if (string[i] == ch)
{
index = i;
}
}
if (index == -1)
{
printf("Not Found");
}
else
{
printf("index = %d", index);
}
return 0;
}
以上是关于[PTA]实验7-3-2 查找指定字符的主要内容,如果未能解决你的问题,请参考以下文章