[PTA]实验7-1-7 查找整数

Posted Spring-_-Bear

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验7-1-7 查找整数相关的知识,希望对你有一定的参考价值。

本题要求从输入的N个整数中查找给定的X。如果找到,输出X的位置(从0开始数);如果没有找到,输出“Not Found”。

输入格式:

输入在第一行中给出两个正整数N(≤20)和X,第二行给出N个整数。数字均不超过长整型,其间以空格分隔。

输出格式:

在一行中输出X的位置,或者“Not Found”。

输入样例1:

5 7
3 5 7 1 9

输出样例1:

2

输入样例2:

5 7
3 5 8 1 9

输出样例2:

Not Found
  • 提交结果:

在这里插入图片描述

  • 源码:
#include<stdio.h>
int main(void)
{
	int array[20];
	int N, X;
	int index = -1;		// 未找到X

	scanf("%d %d", &N, &X);

	for (int i = 0; i < N; i++)
	{
		scanf("%d", &array[i]);
	}

	// 查找X在数组中的位置
	for (int i = 0; i < N; i++)
	{
		if (array[i] == X)
		{
			index = i;
			break;
		}
	}

	if (index == -1)
	{
		printf("Not Found");
	}
	else
	{
		printf("%d", index);
	}

	return 0;
}

以上是关于[PTA]实验7-1-7 查找整数的主要内容,如果未能解决你的问题,请参考以下文章

实验报告

[PTA]实验11-1-3 查找星期

[PTA]实验2-2-5 求整数均值

[PTA]实验10-10 递归实现顺序输出整数

[PTA]实验11-1-8 查找子串

[PTA]实验2-2-7 整数四则运算