[PTA]实验6-9 统计一行文本的单词个数
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验6-9 统计一行文本的单词个数相关的知识,希望对你有一定的参考价值。
本题目要求编写程序统计一行字符中单词的个数。所谓“单词”是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。
输入格式:
输入给出一行字符。
输出格式:
在一行中输出单词个数。
输入样例:
Let's go to room 209.
输出样例:
5
- 提交结果:
- 源码:
#include<stdio.h>
#include<string.h>
int main()
{
char str[1000];
int count = 0;
gets(str); //获得字符串
for (int i = 0; i < strlen(str); i++)
{
if (str[i] != ' ' && (str[i + 1] == ' ' || str[i + 1] == '\\0')) //满足此条件则说明是单词
{
count++;
}
}
printf("%d", count);
return 0;
}
以上是关于[PTA]实验6-9 统计一行文本的单词个数的主要内容,如果未能解决你的问题,请参考以下文章