[PTA]实验2-4-7 求组合数
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验2-4-7 求组合数相关的知识,希望对你有一定的参考价值。
本题要求编写程序,根据公式算出从n个不同元素中取出m个元素(m≤n)的组合数。
建议定义和调用函数fact(n)计算n!,其中n的类型是int,函数类型是double。
输入格式:
输入在一行中给出两个正整数m和n(m≤n),以空格分隔。
输出格式:
按照格式“result = 组合数计算结果”输出。题目保证结果在double类型范围内。
输入样例:
2 7
输出样例:
result = 21
- 提交结果:
- 源码:
#include<stdio.h>
double fact(int n);//求n!
int main(void)
{
int m, n;
int result;
scanf("%d%d", &m, &n);
if (m == n)
{
result = 1;
}
else
{
result = fact(n) / (fact(m) * fact(n - m));
}
printf("result = %d\\n", result);
return 0;
}
// 递归方法求得n的阶乘
double fact(int n)
{
if (n == 1)
{
return 1;
}
else
{
return n * fact(n - 1);
}
}
以上是关于[PTA]实验2-4-7 求组合数的主要内容,如果未能解决你的问题,请参考以下文章