UVA10056 What is the Probability概率

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA10056 What is the Probability概率相关的知识,希望对你有一定的参考价值。

Probability has always been an integrated part of computer algorithms. Where the deterministic algorithms have failed to solve a problem in short time, probabilistic algorithms have come to the rescue. In this problem we are not dealing with any probabilistic algorithm. We will just try to determine the winning probability of a certain player.
    A game is played by throwing a dice like thing (it should not be assumed that it has six sides like an ordinary dice). If a certain event occurs when a player throws the dice (such as getting a 3, getting green side on top or whatever) he is declared the winner. There can be N such player. So the first player will throw the dice, then the second and at last the N-th player and again the first player and so on. When a player gets the desired event he or she is declared winner and playing stops. You will have to determine the winning probability of one (The I-th) of these players.
Input
Input will contain an integer S (S ≤ 1000) at first, which indicates how many sets of inputs are there. The next S lines will contain S sets of inputs. Each line contain an integer N (N ≤ 1000) which denotes the number players, a floating point number p which indicates the probability of the happening of a successful event in a single throw (If success means getting 3 then p is the probability of getting 3 in a single throw. For a normal dice the probability of getting 3 is 1/6), and I (I ≤ N) the serial of the player whose winning probability is to be determined (Serial no varies from 1 to N). You can assume that no invalid probability § value will be given as input.
Output
For each set of input, output in a single line the probability of the I-th player to win. The output floating point number will always have four digits after the decimal point as shown in the sample output.
Sample Input
2
2 0.166666 1
2 0.166666 2
Sample Output
0.5455
0.4545

问题链接UVA10056 What is the Probability
问题简述:(略)
问题分析:概率计算问题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10056 What is the Probability */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    while (t--) {
        int n, i;
        double p;

        scanf("%d%lf%d", &n, &p, &i);

        printf("%.4lf\\n", p == 0 ? 0 : p * pow(1 - p, i - 1) / (1 - pow(1 - p, n)));
    }

    return 0;
}

以上是关于UVA10056 What is the Probability概率的主要内容,如果未能解决你的问题,请参考以下文章

uva10056-概率是多少

What is the rbenv?

The truth is what it is, not what you see

UVA - 10474 Where is the Marble?(排序)

What the $%@! is SPDY

What is the reason that a likelihood function is not a pdf?