[PTA]实验11-2-2 学生成绩链表处理
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验11-2-2 学生成绩链表处理相关的知识,希望对你有一定的参考价值。
本题要求实现两个函数,一个将输入的学生成绩组织成单向链表;另一个将成绩低于某分数线的学生结点从链表中删除。
函数接口定义:
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
函数createlist利用scanf从输入中获取学生的信息,将其组织成单向链表,并返回链表头指针。链表节点结构定义如下:
struct stud_node {
int num; /*学号*/
char name[20]; /*姓名*/
int score; /*成绩*/
struct stud_node *next; /*指向下个结点的指针*/
};
输入为若干个学生的信息(学号、姓名、成绩),当输入学号为0时结束。
函数deletelist从以head为头指针的链表中删除成绩低于min_score的学生,并返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct stud_node {
int num;
char name[20];
int score;
struct stud_node *next;
};
struct stud_node *createlist();
struct stud_node *deletelist( struct stud_node *head, int min_score );
int main()
{
int min_score;
struct stud_node *p, *head = NULL;
head = createlist();
scanf("%d", &min_score);
head = deletelist(head, min_score);
for ( p = head; p != NULL; p = p->next )
printf("%d %s %d\\n", p->num, p->name, p->score);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 zhang 78
2 wang 80
3 li 75
4 zhao 85
0
80
输出样例:
2 wang 80
4 zhao 85
- 提交结果:
- 源码:
#include <stdio.h>
#include <stdlib.h>
struct stud_node {
int num;
char name[20];
int score;
struct stud_node* next;
};
struct stud_node* createlist();
struct stud_node* deletelist(struct stud_node* head, int min_score);
int main()
{
int min_score;
struct stud_node* p, * head = NULL;
head = createlist();
scanf("%d", &min_score);
head = deletelist(head, min_score);
for (p = head; p != NULL; p = p->next)
printf("%d %s %d\\n", p->num, p->name, p->score);
return 0;
}
/* 你的代码将被嵌在这里 */
struct stud_node* createlist()
{
struct stud_node* head, * tail, * temp; // 头节点、尾节点、临时节点
// 为头节点分配内存,数据域不存信息
head = (struct stud_node*)malloc(sizeof(struct stud_node));
// 头节点指向空
head->next = NULL;
// 此时尾节点跟头节点是同一个节点
tail = head;
int number;
scanf("%d", &number);
while (number != 0)
{
// 为临时节点分配内存
temp = (struct stud_node*)malloc(sizeof(struct stud_node));
// 将信息存入临时节点数据域
temp->num = number;
scanf("%s", &temp->name);
scanf("%d", &temp->score);
// temp指向空
temp->next = NULL;
// 将临时节点链接到链表尾
tail->next = temp;
// 更新尾节点为临时节点
tail = temp;
scanf("%d", &number);
}
return head;
}
struct stud_node* deletelist(struct stud_node* head, int min_score)
{
struct stud_node* pCurrent = head; // 当前节点
// 链表为空
if (!head)
{
return NULL;
}
// 由于头节点不存信息,故从头节点的下一节点开始遍历链表
// 当前节点实际为(pCurrent->next)
while (pCurrent->next)
{
// 节点分数小于给定分数,删除该节点
if (pCurrent->next->score < min_score)
{
// 临时节点,保存当前节点pCurrent->next
struct stud_node* temp = pCurrent->next;
// 将当前节点的下个节点的地址覆盖当前节点的地址
pCurrent->next = temp->next;
// 释放之前的节点
free(temp);
}
else
{
pCurrent = pCurrent->next;
}
}
// 头节点不存储值,返回下一节点的地址
head = head->next;
return head;
}
以上是关于[PTA]实验11-2-2 学生成绩链表处理的主要内容,如果未能解决你的问题,请参考以下文章