[PTA]实验11-1-3 查找星期

Posted Spring-_-Bear

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验11-1-3 查找星期相关的知识,希望对你有一定的参考价值。

本题要求实现函数,可以根据下表查找到星期,返回对应的序号。

序号星期
0Sunday
1Monday
2Tuesday
3Wednesday
4Thursday
5Friday
6Saturday

函数接口定义:

int getindex( char *s );

函数getindex应返回字符串s序号。如果传入的参数s不是一个代表星期的字符串,则返回-1。

裁判测试程序样例:

#include <stdio.h>
#include <string.h>

#define MAXS 80

int getindex( char *s );

int main()
{
    int n;
    char s[MAXS];

    scanf("%s", s);
    n = getindex(s);
    if ( n==-1 ) printf("wrong input!\\n");
    else printf("%d\\n", n);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

Tuesday

输出样例1:

2

输入样例2:

today

输出样例2:

wrong input!
  • 提交结果:

在这里插入图片描述

  • 源码:
#include <stdio.h>
#include <string.h>

#define MAXS 80

int getindex(char* s);

int main()
{
    int n;
    char s[MAXS];

    scanf("%s", s);
    n = getindex(s);
    if (n == -1) printf("wrong input!\\n");
    else printf("%d\\n", n);

    return 0;
}

/* 你的代码将被嵌在这里 */
int getindex(char* s)
{
    int index = -1;

    if (strcmp(s, "Sunday") == 0)
    {
        index = 0;
    }
    else if (strcmp(s, "Monday") == 0)
    {
        index = 1;
    }
    else if (strcmp(s, "Tuesday") == 0)
    {
        index = 2;
    }
    else if (strcmp(s, "Wednesday") == 0)
    {
        index = 3;
    }
    else if (strcmp(s, "Thursday") == 0)
    {
        index = 4;
    }
    else if (strcmp(s, "Friday") == 0)
    {
        index = 5;
    }
    else if (strcmp(s, "Saturday") == 0)
    {
        index = 6;
    }

    return index;
}

以上是关于[PTA]实验11-1-3 查找星期的主要内容,如果未能解决你的问题,请参考以下文章

[PTA]实验11-1-8 查找子串

[PTA]实验9-5 查找书籍

[PTA]实验7-3-2 查找指定字符

[PTA]实验8-1-5 在数组中查找指定元素

[PTA]实验7-1-7 查找整数

PTA乙级 (1049 数列的片段和 (20分))