[PTA]实验5-6 使用函数判断完全平方数
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]实验5-6 使用函数判断完全平方数相关的知识,希望对你有一定的参考价值。
本题要求实现一个判断整数是否为完全平方数的简单函数。
函数接口定义:
int IsSquare( int n );
其中n是用户传入的参数,在长整型范围内。如果n是完全平方数,则函数IsSquare必须返回1,否则返回0。
裁判测试程序样例:
#include <stdio.h>
#include <math.h>
int IsSquare( int n );
int main()
{
int n;
scanf("%d", &n);
if ( IsSquare(n) ) printf("YES\\n");
else printf("NO\\n");
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例1:
10
输出样例1:
NO
输入样例2:
100
输出样例2:
YES
- 提交结果:
- 源码:
#include <stdio.h>
#include <math.h>
int IsSquare(int n);
int main()
{
int n;
scanf("%d", &n);
if (IsSquare(n)) printf("YES\\n");
else printf("NO\\n");
return 0;
}
/* 你的代码将被嵌在这里 */
int IsSquare(int n)
{
if ((int)sqrt(n) * (int)sqrt(n) == n)
{
return 1;
}
return 0;
}
以上是关于[PTA]实验5-6 使用函数判断完全平方数的主要内容,如果未能解决你的问题,请参考以下文章