HDU1328 ZOJ1240 IBM Minus One水题

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1328 ZOJ1240 IBM Minus One水题相关的知识,希望对你有一定的参考价值。

IBM Minus One
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9704 Accepted Submission(s): 4643

Problem Description
You may have heard of the book ‘2001 - A Space Odyssey’ by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don’t tell you how the story ends, in case you want to read the book for yourself 😃

After the movie was released and became very popular, there was some discussion as to what the name ‘HAL’ actually meant. Some thought that it might be an abbreviation for ‘Heuristic ALgorithm’. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get … IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

Input
The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

Output
For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing ‘Z’ by ‘A’.

Print a blank line after each test case.

Sample Input
2
HAL
SWERC

Sample Output
String #1
IBM

String #2
TXFSD

Source
Southwestern Europe 1997, Practice

问题链接HDU1328 ZOJ1240 IBM Minus One
问题简述:输入若干个由大写字母组成的字符串,输出一个字符串,其中每个字母都是原字符串中字母的下一个字母。
问题分析:简单题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1328 ZOJ1240 IBM Minus One */

#include <bits/stdc++.h>

using namespace std;

const int N = 50;
char s[N + 1];

int main()
{
    int n, caseno = 0;
    scanf("%d", &n);
    while (n--) {
        scanf("%s", s);
        printf ("String #%d\\n", ++caseno);

        for (int i = 0; s[i]; i++)
            putchar(s[i] == 'Z' ? 'A' : s[i] + 1);
        putchar('\\n');
        putchar('\\n');
    }

    return 0;
}

以上是关于HDU1328 ZOJ1240 IBM Minus One水题的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1240 Asteroids!

HDU 1240 Asteroids!(BFS)

HDU 1240 Asteroids!

IBM Minus One

HDU 3783 ZOJ

HDU1320 ZOJ1201 Inversion水题