POJ2579 LA2858 HDU1218 Blurred Vision水题

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ2579 LA2858 HDU1218 Blurred Vision水题相关的知识,希望对你有一定的参考价值。

Blurred Vision
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2269 Accepted: 1624

Description

Aliasing is the stair-step effect achieved when attempting to represent a smooth curve using a finite number of discrete pixels. Of course, all computer displays consist of a finite number of pixels, and many strategies have been devised to smooth the jagged edges with varying degrees of success.

Boudreaux and Thibodeaux are writing video game rendering software for the next big first-person shooter, and they don’t know much about any of the progress made in the field of anti-aliasing. Therefore, they’ve decided to use a very simplistic (and visually unappealing) method to smooth the ragged edges. Unfortunately, it blurs the entire image, but at least it gets rid of those jaggies!

Normally, the game displays in m x n pixels, but they perform an extra anti-aliasing step that converts that image into an (m - 1) x (n - 1) image. Nobody will notice a pixel missing from each dimension, and they can calculate the new pixels by averaging squares of 4 pixels from the original image (and rounding down). For example, the images below represent the original image (left) and the anti-aliased image (right) using numbers to represent varying shades of black and white.

4 4 4 0
4 4 0 0
4 0 0 0
0 0 0 0
4 3 1
3 1 0
1 0 0

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 3 components:
Start line - A single line:
START R C

where R and C are integers (2 <= (R,C) <= 9) indicating the number of rows and columns in the input image described by this data set.
Original Image - A series of R lines, each of which contains C integers from 0 to 9 inclusive. These integers represent the grayscale value of a pixel in the original image and will not be separated by spaces.
End line - A single line:
END

After the last data set, there will be a single line:

ENDOFINPUT

Output

The output will be the anti-aliased image, which will be R - 1 rows, each with C - 1 integer pixel values. Each pixel in the output will be generated by averaging (and rounding down) the grayscale pixel values of the corresponding square of four pixels in the Original Image.

Sample Input

START 2 2
00
00
END
START 2 9
012345678
012345678
END
START 4 4
4440
4400
4000
0000
END
START 9 9
900000009
090000090
009000900
000909000
000090000
000909000
009000900
090000090
900000009
END
ENDOFINPUT

Sample Output

0
01234567
431
310
100
42000024
24200242
02422420
00244200
00244200
02422420
24200242
42000024

Source

South Central USA 2003

问题链接POJ2579 LA2858 HDU1218 Blurred Vision
问题简述:给定一个矩阵,计算2*2子矩阵的平均值,并输出。
问题分析:水题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2579 LA2858 HDU1218 Blurred Vision */

#include <iostream>
#include <cstdio>

using namespace std;

const int N = 9;
char a[N][N + 1], s[16];
int r, c;

int main()
{
    while (~scanf("%s", s) && s[0] != 'E') {
        scanf("%d%d", &r, &c);
        getchar();
        for (int i = 0; i < r; i++)
            gets(a[i]);

        for (int i = 0; i < r - 1; i++) {
            for (int j = 0; j < c - 1; j++)
                printf("%d", (a[i][j] + a[i + 1][j] + a[i][j + 1] + a[i + 1][j + 1]) / 4 - '0');
            printf("\\n");
        }

        gets(a[0]);
    }

    return 0;
}

以上是关于POJ2579 LA2858 HDU1218 Blurred Vision水题的主要内容,如果未能解决你的问题,请参考以下文章

POJ2033 LA3078 HDU1508 ZOJ2202 AlphacodeDFS+DP

POJ2142 LA3185 HDU1356 The Balance同余方程

POJ1323 LA2521 HDU1338 ZOJ1362 Game Prediction贪心

POJ2092 LA3157 HDU1347 ZOJ2250 Grandpa is Famous排序

POJ2704 HDU1208 LA3390 Pascal‘s Travels递推+记忆化搜索

HDU_2579_bfs