HDU1320 ZOJ1201 Inversion水题

Posted 海岛Blog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1320 ZOJ1201 Inversion水题相关的知识,希望对你有一定的参考价值。

Inversion
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 810 Accepted Submission(s): 450

Problem Description
Let { A1,A2,…,An } be a permutation of the set{ 1,2,…, n}. If i < j and Ai > Aj then the pair (Ai,Aj) is called an “inversion” of the permutation. For example, the permutation {3, 1, 4, 2} has three inversions: (3,1), (3,2) and (4,2).
The inversion table B1,B2,…,Bn of the permutation { A1,A2,…,An } is obtained by letting Bj be the number of elements to the left of j that are greater than j. (In other words, Bj is the number of inversions whose second component is j.) For example, the permutation:
{ 5,9,1,8,2,6,4,7,3 }
has the inversion table
2 3 6 4 0 2 2 1 0
since there are 2 numbers, 5 and 9, to the left of 1; 3 numbers, 5, 9 and 8, to the left of 2; etc.
Perhaps the most important fact about inversions is Marshall Hall’s observation that an inversion table uniquely determines the corresponding permutation. So your task is to convert a permutation to its inversion table, or vise versa, to convert from an inversion table to the corresponding permutation.

Input
The input consists of several test cases. Each test case contains two lines.
The first line contains a single integer N ( 1 <= N <= 50) which indicates the number of elements in the permutation/invertion table.
The second line begins with a single charactor either ‘P’, meaning that the next N integers form a permutation, or ‘I’, meaning that the next N integers form an inversion table.

Output
For each case of the input output a line of intergers, seperated by a single space (no space at the end of the line). If the input is a permutation, your output will be the corresponding inversion table; if the input is an inversion table, your output will be the corresponding permutation.

Sample Input
9
P 5 9 1 8 2 6 4 7 3
9
I 2 3 6 4 0 2 2 1 0
0

Sample Output
2 3 6 4 0 2 2 1 0
5 9 1 8 2 6 4 7 3

Source
Zhejiang University Local Contest 2002, Preliminary

问题链接HDU1320 ZOJ1201 Inversion
问题简述:给定一个序列,求其倒置表。
问题分析:简单问题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1320 ZOJ1201 Inversion */

#include <bits/stdc++.h>

using namespace std;

const int INF = 0x3F3F3F3F;
const int N = 50 + 1;
int p[N], ix[N];
char s[2];

int main()
{
    int n;
    while (~scanf("%d", &n) && n) {
        scanf("%s", s);
        if (s[0] == 'P') {
            for (int i = 1; i <= n; i++) scanf("%d", &p[i]);

            for (int i = 1; i <= n; i++) {
                int cnt = 0;
                for (int j = 1; j <= n; j++)
                    if (p[j] == i) break;
                    else if (p[j] > i) cnt++;
                ix[i] = cnt;
            }

            for (int i = 1; i < n; i++)
                printf("%d ", ix[i]);
            printf("%d\\n", ix[n]);
        } else {
            for (int i = 1; i <= n; i++) {
                scanf("%d", &ix[i]);
                p[i] = INF;
            }
            for (int i = 1; i <= n; i++) {
                int cnt = 0;
                for (int j = 1; j <= n; j++)
                    if (p[j] > i) {
                        if (cnt == ix[i]) {
                            p[j] = i;
                            break;
                        } else
                            cnt++;
                    }
            }

            for (int i = 1; i < n; i++)
                printf("%d ", p[i]);
            printf("%d\\n", p[n]);
        }
    }

    return 0;
}

以上是关于HDU1320 ZOJ1201 Inversion水题的主要内容,如果未能解决你的问题,请参考以下文章

HDU 4911Inversion

hdu 1394 Minimum Inversion Number

HDU4911:Inversion

hdu 6098 Inversion

ACM/ICPC 之 差分约束系统两道(ZOJ2770-POJ1201)

HDU 6098 Inversion 思维