[PTA]习题11-3 计算最长的字符串长度
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]习题11-3 计算最长的字符串长度相关的知识,希望对你有一定的参考价值。
[PTA]习题11-3 计算最长的字符串长度
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
- 提交结果:
- 源码:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len(char* s[], int n);
int main()
{
int i, n;
char* string[MAXN] = { NULL };
scanf("%d", &n);
for (i = 0; i < n; i++) {
string[i] = (char*)malloc(sizeof(char) * MAXS);
scanf("%s", string[i]);
}
printf("%d\\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
int max_len(char* s[], int n)
{
// 先假设第一个字符串长度最长
int strLen = strlen(s[0]);
// 从剩下n-1个字符串中获取其长度,若其比strLen大,则更新strLen的值
for (int i = 1; i < n; i++)
{
if (strlen(s[i]) > strLen)
{
strLen = strlen(s[i]);
}
}
return strLen;
}
以上是关于[PTA]习题11-3 计算最长的字符串长度的主要内容,如果未能解决你的问题,请参考以下文章