[PTA]习题10-2 递归求阶乘和
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]习题10-2 递归求阶乘和相关的知识,希望对你有一定的参考价值。
[PTA]习题10-2 递归求阶乘和
本题要求实现一个计算非负整数阶乘的简单函数,并利用该函数求 1!+2!+3!+…+n! 的值。
函数接口定义:
double fact( int n );
double factsum( int n );
函数fact应返回n的阶乘,建议用递归实现。函数factsum应返回 1!+2!+…+n! 的值。题目保证输入输出在双精度范围内。
裁判测试程序样例:
#include <stdio.h>
double fact( int n );
double factsum( int n );
int main()
{
int n;
scanf("%d",&n);
printf("fact(%d) = %.0f\\n", n, fact(n));
printf("sum = %.0f\\n", factsum(n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例1:
10
输出样例1:
fact(10) = 3628800
sum = 4037913
输入样例2:
0
输出样例2:
fact(0) = 1
sum = 0
- 提交结果:
- 源码:
#include <stdio.h>
double fact(int n);
double factsum(int n);
int main()
{
int n;
scanf("%d", &n);
printf("fact(%d) = %.0f\\n", n, fact(n));
printf("sum = %.0f\\n", factsum(n));
return 0;
}
/* 你的代码将被嵌在这里 */
double fact(int n)
{
double result;
// 递归出口
if (n == 0 || n == 1)
{
result = 1;
}
else
{
result = n * fact(n - 1);
}
return result;
}
double factsum(int n)
{
double result = 0;
for (int i = 1; i <= n; i++)
{
// 调用函数求和
result += fact(i);
}
return result;
}
以上是关于[PTA]习题10-2 递归求阶乘和的主要内容,如果未能解决你的问题,请参考以下文章