[PTA]习题9-2 计算两个复数之积
Posted Spring-_-Bear
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[PTA]习题9-2 计算两个复数之积相关的知识,希望对你有一定的参考价值。
[PTA]习题9-2 计算两个复数之积
本题要求实现一个计算复数之积的简单函数。
函数接口定义:
struct complex multiply(struct complex x, struct complex y);
其中struct complex是复数结构体,其定义如下:
struct complex{
int real;
int imag;
};
裁判测试程序样例:
#include <stdio.h>
struct complex{
int real;
int imag;
};
struct complex multiply(struct complex x, struct complex y);
int main()
{
struct complex product, x, y;
scanf("%d%d%d%d", &x.real, &x.imag, &y.real, &y.imag);
product = multiply(x, y);
printf("(%d+%di) * (%d+%di) = %d + %di\\n",
x.real, x.imag, y.real, y.imag, product.real, product.imag);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
3 4 5 6
输出样例:
(3+4i) * (5+6i) = -9 + 38i
- 提交结果:
- 源码:
#include <stdio.h>
struct complex {
int real;
int imag;
};
struct complex multiply(struct complex x, struct complex y);
int main()
{
struct complex product, x, y;
scanf("%d%d%d%d", &x.real, &x.imag, &y.real, &y.imag);
product = multiply(x, y);
printf("(%d+%di) * (%d+%di) = %d + %di\\n",
x.real, x.imag, y.real, y.imag, product.real, product.imag);
return 0;
}
/* 你的代码将被嵌在这里 */
struct complex multiply(struct complex x, struct complex y)
{
struct complex result;
// 实部为x与y两实部之积与两虚部之积的差,因为i²=-1
result.real = x.real * y.real - x.imag * y.imag;
// 虚部为x的实部与y的虚部之积与y的实部与x的虚部之积的和
result.imag = x.real * y.imag + y.real * x.imag;
return result;
}
以上是关于[PTA]习题9-2 计算两个复数之积的主要内容,如果未能解决你的问题,请参考以下文章